summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nautilus-jungledisk/Manifest3
-rw-r--r--gnome-extra/nautilus-jungledisk/metadata.xml8
-rw-r--r--gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild54
3 files changed, 65 insertions, 0 deletions
diff --git a/gnome-extra/nautilus-jungledisk/Manifest b/gnome-extra/nautilus-jungledisk/Manifest
new file mode 100644
index 0000000..5a72575
--- /dev/null
+++ b/gnome-extra/nautilus-jungledisk/Manifest
@@ -0,0 +1,3 @@
+DIST nautilus-jungledisk-1.0.tar.gz 301567 RMD160 2d4040ce5cdd38c3d6ffa3e13136d3fd190d96c3 SHA1 d0831f2b35b87c14b2d268efe0b2b3b4b6d8b35a SHA256 c389d71859fbd57cf91706966028b0cce80af41af1cc3e693ec24d55631a1581
+EBUILD nautilus-jungledisk-1.0.ebuild 2071 RMD160 ffe2f35a5a076866d074ba98cefb78352174d994 SHA1 7fc65c9c85a4b66bb94cdcea57797f70c92d3a27 SHA256 2d718e21e8fa332803a109deb2c680068b27a7d1b6e7f25cfdc18a7fa1a7339b
+MISC metadata.xml 235 RMD160 87757f9ef9a2e9aba6b5a821e890d9402c419dcf SHA1 76e5aed381efb463bce230fd8404f59700e05e4e SHA256 b028713ffa8477f7bac52f8483b90f31aab061d8f81ad20127f20a45126ac02d
diff --git a/gnome-extra/nautilus-jungledisk/metadata.xml b/gnome-extra/nautilus-jungledisk/metadata.xml
new file mode 100644
index 0000000..367c49b
--- /dev/null
+++ b/gnome-extra/nautilus-jungledisk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>david@triquetradevelopment.com</email>
+</maintainer>
+</pkgmetadata>
diff --git a/gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild b/gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild
new file mode 100644
index 0000000..8391122
--- /dev/null
+++ b/gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Networked storage/backup using Rackspace or Amazon's S3 service."
+HOMEPAGE="http://www.jungledisk.com"
+SRC_URI_BASE="https://downloads.jungledisk.com/31beta/"
+SRC_URI="${SRC_URI_BASE}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="gnome-base/nautilus
+ gnome-base/gconf
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/gnome-desktop
+ || ( net-fs/junglediskdesktop net-fs/junglediskworkgroup net-fs/junglediskserver )"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install of jungledisk nautilus plugin failed."
+ dodoc README || die
+}
+
+pkg_postinst() {
+ echo
+ elog "- You can view the release notes at:"
+ elog " https://www.jungledisk.com/downloads/business/workgroup/releasenotes.aspx"
+ echo
+ elog "Nautilus-Jungle Disk is a Nautilus extension for Jungle Disk. This"
+ elog "extension will probably incorporate more functionality in the future but for"
+ elog "now it's primary purpose is to provide file sharing capability for Jungle Disk's"
+ elog "new Public File Sharing capability made available in 3.10. This allows a user to"
+ elog "right-click on (almost) any file in Nautilus and share the file with another user."
+ elog "This is accomplished by simply launching the default web browser and pointing it to"
+ elog "the local Jungle Disk service that will then share the file or files. Sharing"
+ elog "folders is currently no supported, so if a folder is selected the user will"
+ elog "not see the 'Share with Jungle Disk...' item in the context menu."
+ echo
+ elog "Once installed, the user will need to log out and back"
+ elog "in, *or*, Nautilus can simply be restarted with."
+ elog "$ nautilus -q"
+ echo
+ elog "This should cause Nautilus to quit and restart. If Nautilus"
+ elog "does not restart, just run it manually to start it or log out and back in."
+}