summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild')
-rw-r--r--gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild b/gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild
new file mode 100644
index 0000000..8391122
--- /dev/null
+++ b/gnome-extra/nautilus-jungledisk/nautilus-jungledisk-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Networked storage/backup using Rackspace or Amazon's S3 service."
+HOMEPAGE="http://www.jungledisk.com"
+SRC_URI_BASE="https://downloads.jungledisk.com/31beta/"
+SRC_URI="${SRC_URI_BASE}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="gnome-base/nautilus
+ gnome-base/gconf
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/gnome-desktop
+ || ( net-fs/junglediskdesktop net-fs/junglediskworkgroup net-fs/junglediskserver )"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install of jungledisk nautilus plugin failed."
+ dodoc README || die
+}
+
+pkg_postinst() {
+ echo
+ elog "- You can view the release notes at:"
+ elog " https://www.jungledisk.com/downloads/business/workgroup/releasenotes.aspx"
+ echo
+ elog "Nautilus-Jungle Disk is a Nautilus extension for Jungle Disk. This"
+ elog "extension will probably incorporate more functionality in the future but for"
+ elog "now it's primary purpose is to provide file sharing capability for Jungle Disk's"
+ elog "new Public File Sharing capability made available in 3.10. This allows a user to"
+ elog "right-click on (almost) any file in Nautilus and share the file with another user."
+ elog "This is accomplished by simply launching the default web browser and pointing it to"
+ elog "the local Jungle Disk service that will then share the file or files. Sharing"
+ elog "folders is currently no supported, so if a folder is selected the user will"
+ elog "not see the 'Share with Jungle Disk...' item in the context menu."
+ echo
+ elog "Once installed, the user will need to log out and back"
+ elog "in, *or*, Nautilus can simply be restarted with."
+ elog "$ nautilus -q"
+ echo
+ elog "This should cause Nautilus to quit and restart. If Nautilus"
+ elog "does not restart, just run it manually to start it or log out and back in."
+}