aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Broadhead <jamesbroadhead@gmail.com>2012-01-19 21:37:10 +0000
committerJames Broadhead <jamesbroadhead@gmail.com>2012-01-19 21:37:10 +0000
commit8a5e6e7e395be96045bb3ed06045d2276d82abc9 (patch)
tree8bc78d25b5ff033792a9b163888638be9b003a99
parentBump selenium (diff)
downloadjamesbroadhead-8a5e6e7e395be96045bb3ed06045d2276d82abc9.tar.gz
jamesbroadhead-8a5e6e7e395be96045bb3ed06045d2276d82abc9.tar.bz2
jamesbroadhead-8a5e6e7e395be96045bb3ed06045d2276d82abc9.zip
Add a snapshot of gap
-rw-r--r--media-libs/gap/Manifest4
-rw-r--r--media-libs/gap/gap-0.1_pre20111212.ebuild69
-rw-r--r--media-libs/gap/gap-9999.ebuild3
-rw-r--r--media-libs/gap/metadata.xml25
4 files changed, 98 insertions, 3 deletions
diff --git a/media-libs/gap/Manifest b/media-libs/gap/Manifest
index f02a7fc..962e906 100644
--- a/media-libs/gap/Manifest
+++ b/media-libs/gap/Manifest
@@ -1 +1,3 @@
-EBUILD gap-9999.ebuild 1663 RMD160 6996c546583d2d8ce861e1ba4dacc4033331ff06 SHA1 284410286eb4ffadf2b51c74038647f47c206f7e SHA256 fb5a3a1fb9f20d2601916c77af7c9150f720c5f59d4b3eb5e7ab59f1426abdbc
+EBUILD gap-0.1_pre20111212.ebuild 1698 RMD160 aa5e40d0811e65f66c65d16e469739399c1cbf08 SHA1 8b563b19ef33bc35f615ae44e079fcef2a5a270a SHA256 8ea2568ae030c5ed04fd9b834d62773671a97207b398cef1a497c435c673a517
+EBUILD gap-9999.ebuild 1615 RMD160 d0905576336bdc1c895d3370beb4e0f28bba48cd SHA1 553c76193e4e8fb812c2370a00e6951b7e8e05e9 SHA256 0f261293373ab89954031a79e1e6be818d182be7899c1c14fd1cb8c0f0459c0b
+MISC metadata.xml 757 RMD160 a380880eea456fcd409d68328e5ffb3c2e6452e0 SHA1 d4b2b96d1f1a868cecf305c844f829269517a8a9 SHA256 df3a5547f4f13a637234880808c53508b802d12892c69d257e83d615b652ef36
diff --git a/media-libs/gap/gap-0.1_pre20111212.ebuild b/media-libs/gap/gap-0.1_pre20111212.ebuild
new file mode 100644
index 0000000..a6d5215
--- /dev/null
+++ b/media-libs/gap/gap-0.1_pre20111212.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit flag-o-matic mercurial
+
+DESCRIPTION="Gapless Audio Player Library for Goggles Musicmanager (media-sound/gogglesmm)"
+HOMEPAGE="http://code.google.com/p/gogglesmm/"
+EHG_REPO_URI="https://${PN}.gogglesmm.googlecode.com/hg/"
+
+# Tested with media-sound/gogglesmm-0.12.6
+EHG_REVISION="c6ba5fce528a"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac alsa cdda ffmpeg flac jack mad mms musepack ogg pulseaudio samba libsamplerate vorbis"
+
+DEPEND=">=x11-libs/fox-1.7.30
+ dev-libs/glib:2
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ cdda? ( dev-libs/libcdio )
+ ffmpeg? ( media-video/ffmpeg )
+ flac? ( media-libs/flac )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.118.0 )
+ mad? ( media-libs/libmad )
+ mms? ( media-libs/libmms )
+ musepack? ( media-sound/musepack-tools )
+ ogg? ( media-libs/libogg )
+ pulseaudio? ( media-sound/pulseaudio )
+ samba? ( net-fs/samba[client] )
+ libsamplerate? ( media-libs/libsamplerate )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's/dash/sh/' configure || die
+
+ # patch in --shared -fPIC into config.make ?
+
+}
+
+src_configure() {
+ econf \
+ $(use_with aac faad) \
+ $(use_with alsa ) \
+ $(use_with cdda ) \
+ $(use_with ffmpeg avcodec) \
+ $(use_with flac ) \
+ $(use_with jack ) \
+ $(use_with mad ) \
+ $(use_with mms ) \
+ $(use_with musepack ) \
+ $(use_with ogg ) \
+ $(use_with pulseaudio pulse ) \
+ $(use_with samba ) \
+ $(use_with libsamplerate samplerate) \
+ $(use_with vorbis ) \
+ --enable-debug
+}
+
+src_compile() {
+ append-ldflags -shared -fPIC || die
+
+ emake
+}
diff --git a/media-libs/gap/gap-9999.ebuild b/media-libs/gap/gap-9999.ebuild
index 1346392..e318a7f 100644
--- a/media-libs/gap/gap-9999.ebuild
+++ b/media-libs/gap/gap-9999.ebuild
@@ -16,7 +16,7 @@ KEYWORDS=""
IUSE="aac alsa cdda ffmpeg flac jack mad mms musepack ogg pulseaudio samba libsamplerate vorbis"
DEPEND=">=x11-libs/fox-1.7.30
- dev-libs/glib:2
+ dev-libs/glib:2
aac? ( media-libs/faad2 )
alsa? ( media-libs/alsa-lib )
cdda? ( dev-libs/libcdio )
@@ -57,7 +57,6 @@ src_configure() {
$(use_with libsamplerate samplerate) \
$(use_with vorbis ) \
--enable-debug
- --without-rsound # not in portage or sunrise
}
src_compile() {
diff --git a/media-libs/gap/metadata.xml b/media-libs/gap/metadata.xml
new file mode 100644
index 0000000..aad3be1
--- /dev/null
+++ b/media-libs/gap/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription>
+ Goggles Audio Player Library used by media-sound/gogglesmm
+ </longdescription>
+
+ <maintainer>
+ <email>jamesbroadhead@gmail.com</email>
+ <name>James Broadhead</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+
+ <upstream>
+ <maintainer>
+ <email>gogglesmm@googlegroups.com</email>
+ <name>Sander Jansen</name>
+ </maintainer>
+ <changelog>http://code.google.com/p/gogglesmm/wiki/ChangeLog</changelog>
+ <doc>http://code.google.com/p/gogglesmm/w/list</doc>
+ <bugs-to>http://code.google.com/p/gogglesmm/issues/list</bugs-to>
+ </upstream>
+
+</pkgmetadata>