aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gap/gap-0.1_pre20111212.ebuild')
-rw-r--r--media-libs/gap/gap-0.1_pre20111212.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/gap/gap-0.1_pre20111212.ebuild b/media-libs/gap/gap-0.1_pre20111212.ebuild
new file mode 100644
index 0000000..a6d5215
--- /dev/null
+++ b/media-libs/gap/gap-0.1_pre20111212.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit flag-o-matic mercurial
+
+DESCRIPTION="Gapless Audio Player Library for Goggles Musicmanager (media-sound/gogglesmm)"
+HOMEPAGE="http://code.google.com/p/gogglesmm/"
+EHG_REPO_URI="https://${PN}.gogglesmm.googlecode.com/hg/"
+
+# Tested with media-sound/gogglesmm-0.12.6
+EHG_REVISION="c6ba5fce528a"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac alsa cdda ffmpeg flac jack mad mms musepack ogg pulseaudio samba libsamplerate vorbis"
+
+DEPEND=">=x11-libs/fox-1.7.30
+ dev-libs/glib:2
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ cdda? ( dev-libs/libcdio )
+ ffmpeg? ( media-video/ffmpeg )
+ flac? ( media-libs/flac )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.118.0 )
+ mad? ( media-libs/libmad )
+ mms? ( media-libs/libmms )
+ musepack? ( media-sound/musepack-tools )
+ ogg? ( media-libs/libogg )
+ pulseaudio? ( media-sound/pulseaudio )
+ samba? ( net-fs/samba[client] )
+ libsamplerate? ( media-libs/libsamplerate )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's/dash/sh/' configure || die
+
+ # patch in --shared -fPIC into config.make ?
+
+}
+
+src_configure() {
+ econf \
+ $(use_with aac faad) \
+ $(use_with alsa ) \
+ $(use_with cdda ) \
+ $(use_with ffmpeg avcodec) \
+ $(use_with flac ) \
+ $(use_with jack ) \
+ $(use_with mad ) \
+ $(use_with mms ) \
+ $(use_with musepack ) \
+ $(use_with ogg ) \
+ $(use_with pulseaudio pulse ) \
+ $(use_with samba ) \
+ $(use_with libsamplerate samplerate) \
+ $(use_with vorbis ) \
+ --enable-debug
+}
+
+src_compile() {
+ append-ldflags -shared -fPIC || die
+
+ emake
+}