summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-07-03 23:40:36 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-07-03 23:40:36 -0400
commit3b80518b1ce05224a8032767a7185ac1fa1164d9 (patch)
tree237899b22b09cfbf39f7bccb9288da8deef88a26
parentAdd zsxd parody game... (diff)
downloadArmageddon-3b80518b1ce05224a8032767a7185ac1fa1164d9.tar.gz
Armageddon-3b80518b1ce05224a8032767a7185ac1fa1164d9.tar.bz2
Armageddon-3b80518b1ce05224a8032767a7185ac1fa1164d9.zip
Add live ebuilds for solarus, zsdx and zsxd...
git version currently not working.
-rw-r--r--games-engines/solarus/solarus-9999.ebuild39
-rw-r--r--games-rpg/zsdx/zsdx-9999.ebuild33
-rw-r--r--games-rpg/zsxd/zsxd-9999.ebuild33
3 files changed, 105 insertions, 0 deletions
diff --git a/games-engines/solarus/solarus-9999.ebuild b/games-engines/solarus/solarus-9999.ebuild
new file mode 100644
index 0000000..afc1eec
--- /dev/null
+++ b/games-engines/solarus/solarus-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games cmake-utils git-2
+
+DESCRIPTION="An open-source Zelda-like 2D game engine"
+HOMEPAGE="http://www.solarus-games.org/"
+EGIT_REPO_URI="git://github.com/christopho/${PN}.git
+ https://github.com/christopho/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ media-libs/libmodplug
+ media-libs/libvorbis
+ dev-lang/lua
+ media-libs/openal
+ dev-games/physfs
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/games-rpg/zsdx/zsdx-9999.ebuild b/games-rpg/zsdx/zsdx-9999.ebuild
new file mode 100644
index 0000000..18fc3c9
--- /dev/null
+++ b/games-rpg/zsdx/zsdx-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games cmake-utils git-2
+
+DESCRIPTION="A free 2D Zelda fangame"
+HOMEPAGE="http://www.solarus-games.org/"
+EGIT_REPO_URI="git://github.com/christopho/${PN}.git
+ https://github.com/christopho/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="=games-engines/solarus-9999"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry ${PN} "Zelda: Mystery of Solarus DX"
+}
diff --git a/games-rpg/zsxd/zsxd-9999.ebuild b/games-rpg/zsxd/zsxd-9999.ebuild
new file mode 100644
index 0000000..9395e78
--- /dev/null
+++ b/games-rpg/zsxd/zsxd-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games cmake-utils git-2
+
+DESCRIPTION="A free 2D Zelda fangame parody"
+HOMEPAGE="http://www.solarus-games.org/"
+EGIT_REPO_URI="git://github.com/christopho/${PN}.git
+ https://github.com/christopho/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="=games-engines/solarus-9999"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry ${PN} "Zelda: Mystery of Solarus XD"
+}