summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/zsxd/zsxd-9999.ebuild')
-rw-r--r--games-rpg/zsxd/zsxd-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-rpg/zsxd/zsxd-9999.ebuild b/games-rpg/zsxd/zsxd-9999.ebuild
new file mode 100644
index 0000000..9395e78
--- /dev/null
+++ b/games-rpg/zsxd/zsxd-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games cmake-utils git-2
+
+DESCRIPTION="A free 2D Zelda fangame parody"
+HOMEPAGE="http://www.solarus-games.org/"
+EGIT_REPO_URI="git://github.com/christopho/${PN}.git
+ https://github.com/christopho/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="=games-engines/solarus-9999"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry ${PN} "Zelda: Mystery of Solarus XD"
+}