aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:27:16 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commite6420f69f3fc1a514a3bf7da8e750067388fb676 (patch)
treea775fa5808d702881ab47bac460819e6b84b83c5
parentRevert "sys-devel/llvm-toolchain-symlinks: Remove LLVM 14" (diff)
downloadgerislay-e6420f69f3fc1a514a3bf7da8e750067388fb676.tar.gz
gerislay-e6420f69f3fc1a514a3bf7da8e750067388fb676.tar.bz2
gerislay-e6420f69f3fc1a514a3bf7da8e750067388fb676.zip
Revert "sys-devel/llvmgold: Remove LLVM 14"
This reverts commit fbced24b968a1e06cd11a2b13cdce658fca77fc7. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--sys-devel/llvmgold/llvmgold-14.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-devel/llvmgold/llvmgold-14.ebuild b/sys-devel/llvmgold/llvmgold-14.ebuild
new file mode 100644
index 0000000..484ce44
--- /dev/null
+++ b/sys-devel/llvmgold/llvmgold-14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="LLVMgold plugin symlink for autoloading"
+HOMEPAGE="https://llvm.org/"
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux"
+
+RDEPEND="
+ sys-devel/llvm:${PV}[binutils-plugin]
+ !sys-devel/llvm:0
+"
+
+src_install() {
+ dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
+ dosym "../../../../lib/llvm/${PV}/$(get_libdir)/LLVMgold.so" \
+ "/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
+}