aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:27:12 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commit4acf0e262e51864f3540e407ab5c535fa79f5bb3 (patch)
tree106cc2718b99728b43f3185766fe1e344ba69ac9
parentRevert "sys-devel/llvm: Remove LLVM 14" (diff)
downloadgerislay-4acf0e262e51864f3540e407ab5c535fa79f5bb3.tar.gz
gerislay-4acf0e262e51864f3540e407ab5c535fa79f5bb3.tar.bz2
gerislay-4acf0e262e51864f3540e407ab5c535fa79f5bb3.zip
Revert "sys-devel/llvm-toolchain-symlinks: Remove LLVM 14"
This reverts commit 471ad5391e20fe6f662848f6d7bcfcb400ed2b21. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-14-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-14-r1.ebuild b/sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-14-r1.ebuild
new file mode 100644
index 0000000..4440957
--- /dev/null
+++ b/sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-14-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Symlinks to use LLVM on binutils-free system"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="multilib-symlinks +native-symlinks"
+
+RDEPEND="
+ sys-devel/llvm:${SLOT}
+"
+
+src_install() {
+ use native-symlinks || return
+
+ local tools=(
+ addr2line ar dlltool nm objcopy objdump ranlib readelf size
+ strings strip windres
+ )
+ local chosts=( "${CHOST}" )
+ if use multilib-symlinks; then
+ local abi
+ for abi in $(get_all_abis); do
+ chosts+=( "$(get_abi_CHOST "${abi}")" )
+ done
+ fi
+
+ local chost t
+ local dest=/usr/lib/llvm/${SLOT}/bin
+ dodir "${dest}"
+ for t in "${tools[@]}"; do
+ dosym "llvm-${t}" "${dest}/${t}"
+ done
+ for chost in "${chosts[@]}"; do
+ for t in "${tools[@]}"; do
+ dosym "llvm-${t}" "${dest}/${chost}-${t}"
+ done
+ done
+}