aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:31:11 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commit11d1f79496f09e24f5a7517641dff680879d803d (patch)
tree791352462ea6d17ddf33df07040744ec1366a6a8
parentRevert "sys-devel/clang-runtime: Remove LLVM 14" (diff)
downloadgerislay-11d1f79496f09e24f5a7517641dff680879d803d.tar.gz
gerislay-11d1f79496f09e24f5a7517641dff680879d803d.tar.bz2
gerislay-11d1f79496f09e24f5a7517641dff680879d803d.zip
Revert "dev-libs/libclc: Remove LLVM 14"
This reverts commit f8a29eb254fa61e19f59fa187da4207ce2e0db67. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--dev-libs/libclc/libclc-14.0.6.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/libclc/libclc-14.0.6.ebuild b/dev-libs/libclc/libclc-14.0.6.ebuild
new file mode 100644
index 0000000..5464d12
--- /dev/null
+++ b/dev-libs/libclc/libclc-14.0.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+inherit cmake llvm llvm.org python-any-r1
+
+DESCRIPTION="OpenCL C library"
+HOMEPAGE="https://libclc.llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions || ( MIT BSD )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_r600 video_cards_radeonsi"
+IUSE="${IUSE_VIDEO_CARDS}"
+REQUIRED_USE="|| ( ${IUSE_VIDEO_CARDS} )"
+
+LLVM_MAX_SLOT=14
+BDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ sys-devel/clang:14
+ sys-devel/clang:13
+ )
+"
+
+LLVM_COMPONENTS=( libclc )
+llvm.org_set_globals
+
+llvm_check_deps() {
+ has_version -b "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ # we do not need llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local libclc_targets=()
+
+ use video_cards_nvidia && libclc_targets+=(
+ "nvptx--"
+ "nvptx64--"
+ "nvptx--nvidiacl"
+ "nvptx64--nvidiacl"
+ )
+ use video_cards_r600 && libclc_targets+=(
+ "r600--"
+ )
+ use video_cards_radeonsi && libclc_targets+=(
+ "amdgcn--"
+ "amdgcn-mesa-mesa3d"
+ "amdgcn--amdhsa"
+ )
+ # TODO: spirv
+ [[ ${#libclc_targets[@]} ]] || die "libclc target missing!"
+
+ libclc_targets=${libclc_targets[*]}
+ local mycmakeargs=(
+ -DLIBCLC_TARGETS_TO_BUILD="${libclc_targets// /;}"
+ -DLLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
+ )
+ cmake_src_configure
+}