aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:31:05 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commitd6516d2ff64ed06c833f3169d9dff72089d23428 (patch)
treeb1f147c5a0a788804ac3a3fb63c54a9e1e13b5d8
parentRevert "sys-libs/libomp: Remove LLVM 14" (diff)
downloadgerislay-d6516d2ff64ed06c833f3169d9dff72089d23428.tar.gz
gerislay-d6516d2ff64ed06c833f3169d9dff72089d23428.tar.bz2
gerislay-d6516d2ff64ed06c833f3169d9dff72089d23428.zip
Revert "sys-devel/clang-runtime: Remove LLVM 14"
This reverts commit 4a5b01b87ce676e9250c90364b0d6b35ffb38ed5. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild
new file mode 100644
index 0000000..9837077
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"