summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/libqb')
-rw-r--r--sys-cluster/libqb/Manifest5
-rw-r--r--sys-cluster/libqb/libqb-0.13.0.ebuild52
-rw-r--r--sys-cluster/libqb/libqb-0.14.3.ebuild52
-rw-r--r--sys-cluster/libqb/libqb-0.14.4.ebuild52
-rw-r--r--sys-cluster/libqb/libqb-0.17.0.ebuild52
-rw-r--r--sys-cluster/libqb/libqb-0.17.1.ebuild52
-rw-r--r--sys-cluster/libqb/metadata.xml8
7 files changed, 273 insertions, 0 deletions
diff --git a/sys-cluster/libqb/Manifest b/sys-cluster/libqb/Manifest
new file mode 100644
index 000000000000..3f0eecd810d2
--- /dev/null
+++ b/sys-cluster/libqb/Manifest
@@ -0,0 +1,5 @@
+DIST libqb-0.13.0.tar.xz 363096 SHA256 2d54c5cd33ee1b7a362ccbc8453f277fa3a350c5302428b24f83073f483a7f33
+DIST libqb-0.14.3.tar.xz 367956 SHA256 c1c80b47c9ad737690461a580ae49dac810743cf94d56dd1f36300c675b68186 SHA512 2494a815cee2ab7e3595e6aec00f3c4950628670e78abd223034414e8f58ac5dbba7b4825f6ad39fd5c68b6e3156e0dfe419ff99ad22782083bf111009cb2075 WHIRLPOOL 6ac42a0bdf70bad0376808922756a85ace5f1a106203a415eb3963de16426c21058824fc6458bb776c3c33bf17374b0612bbf712f2f68ddd0f30ee94c9f91b49
+DIST libqb-0.14.4.tar.xz 370336 SHA256 f518d146cdc6f820e9ed84d35cc3a447ea6fc51a6f2b6b3c2cb030d71eba0d7e SHA512 7437444f688f674fedb962309853418adc21e7aa6b0d3e639cef9e9453419e15535c078d77a7ac293b49adee1225093c15dbaccf44a367f4726e7f6f75ccd9b3 WHIRLPOOL 4d9b562fc6645955d875a39728c15acc593ade5e675961178e4dd7472949c902d6c437a6540da1bbf651ea9894f7de2c8d1f1580f0a4afb2b734f4fbed913266
+DIST libqb-0.17.0.tar.xz 384240 SHA256 555c5c43275f519d323a807652fad863c3528c2644b9b6e29cb9eafbda79d45a SHA512 97ca5e64788c0ec8d8afa14854d245fd0b3bdcfe144e0e3ee9d07d6672c5279d7a91bf647524047375745e28a674658dfb4814a1fbff3b45d538c57469ef31bb WHIRLPOOL c7fb543e928c11c463d6f25bc64e9f4963959d01c26ffd8d10571eeca2716cb360153845517a08e6abb61f40ca414b3efb2f84dfebd988b7dd501ea122f95cfb
+DIST libqb-0.17.1.tar.xz 386304 SHA256 7a2115f83bfe20eaa5f2e4ed235e8f2994235d3b87e3e5ca41ba47b320f12e29 SHA512 9705b291a61ca278fd0c9ab631af2cb844cdfc73b19501dd2e12eb162b37f0eded800860127a8a5c5c7c2a0e8db53e4780d3ab9697b099f4560a9a87aa8ec9ca WHIRLPOOL 8b853fd6e26eca02605a49c5b9c0f97a41e98c5667dadd9a9c3ad36024ec1baacf764e40a774c83938d80ea686af61de0474c390337c16673f2abcbe983ec067
diff --git a/sys-cluster/libqb/libqb-0.13.0.ebuild b/sys-cluster/libqb/libqb-0.13.0.ebuild
new file mode 100644
index 000000000000..3f128230d092
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.13.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}
diff --git a/sys-cluster/libqb/libqb-0.14.3.ebuild b/sys-cluster/libqb/libqb-0.14.3.ebuild
new file mode 100644
index 000000000000..c7d13ceaa4d4
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.14.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}
diff --git a/sys-cluster/libqb/libqb-0.14.4.ebuild b/sys-cluster/libqb/libqb-0.14.4.ebuild
new file mode 100644
index 000000000000..146081779c39
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.14.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 hppa ~x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}
diff --git a/sys-cluster/libqb/libqb-0.17.0.ebuild b/sys-cluster/libqb/libqb-0.17.0.ebuild
new file mode 100644
index 000000000000..2b3c7ec5b057
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.17.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}
diff --git a/sys-cluster/libqb/libqb-0.17.1.ebuild b/sys-cluster/libqb/libqb-0.17.1.ebuild
new file mode 100644
index 000000000000..02a8930a03ee
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.17.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}
diff --git a/sys-cluster/libqb/metadata.xml b/sys-cluster/libqb/metadata.xml
new file mode 100644
index 000000000000..c856cec9fa6a
--- /dev/null
+++ b/sys-cluster/libqb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <upstream>
+ <remote-id type="github">asalkeld/libqb</remote-id>
+ </upstream>
+</pkgmetadata>