summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/flake8-3.0.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/flake8/flake8-3.0.4.ebuild b/dev-python/flake8/flake8-3.0.4.ebuild
index 841e387721aa..9dc4a498f686 100644
--- a/dev-python/flake8/flake8-3.0.4.ebuild
+++ b/dev-python/flake8/flake8-3.0.4.ebuild
@@ -44,7 +44,10 @@ PDEPEND="
python_prepare_all() {
# Gentoo has flake8 support restored in >=pep8-1.6.2-r1.
- sed -e 's:, != 1.6.2::' -i setup.py || die
+ sed -i -e 's:, != 1.6.2::' setup.py || die
+ # Flake8 falsely assumes it needs pytest-runner unconditionally and will
+ # try to install it, causing sandbox violations.
+ sed -i -e "/setup_requires=\['pytest-runner'\],/d" setup.py || die
distutils-r1_python_prepare_all
}