summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-09-07 10:42:51 +0200
committerTobias Klausmann <klausman@gentoo.org>2016-09-07 10:45:05 +0200
commit098e5caa61c32f8aba9d3323ae16994a4c56a81e (patch)
tree688b303ad58e8fed950897e3e35170d07a96e4e1 /dev-python/flake8
parentdev-ml/sequence: bump ocaml dep, bug #591402 (diff)
downloadgentoo-098e5caa61c32f8aba9d3323ae16994a4c56a81e.tar.gz
gentoo-098e5caa61c32f8aba9d3323ae16994a4c56a81e.tar.bz2
gentoo-098e5caa61c32f8aba9d3323ae16994a4c56a81e.zip
dev-python/flake8: Stop build from trying to install pytest-runner
The build system unconditionally requires pytest-runner, which we may not install (if test is not in FEATURES). I then "helpfully" tries to install it, causing sandbox violations.
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/flake8-3.0.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/flake8/flake8-3.0.4.ebuild b/dev-python/flake8/flake8-3.0.4.ebuild
index 841e387721aa..9dc4a498f686 100644
--- a/dev-python/flake8/flake8-3.0.4.ebuild
+++ b/dev-python/flake8/flake8-3.0.4.ebuild
@@ -44,7 +44,10 @@ PDEPEND="
python_prepare_all() {
# Gentoo has flake8 support restored in >=pep8-1.6.2-r1.
- sed -e 's:, != 1.6.2::' -i setup.py || die
+ sed -i -e 's:, != 1.6.2::' setup.py || die
+ # Flake8 falsely assumes it needs pytest-runner unconditionally and will
+ # try to install it, causing sandbox violations.
+ sed -i -e "/setup_requires=\['pytest-runner'\],/d" setup.py || die
distutils-r1_python_prepare_all
}