summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-1.8-r1.ebuild20
-rw-r--r--app-emulation/wine/wine-1.8.1-r1.ebuild20
-rw-r--r--app-emulation/wine/wine-1.8.2.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.10.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.11.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.4-r1.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.5-r1.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.6-r1.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.7-r1.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.8.ebuild20
-rw-r--r--app-emulation/wine/wine-1.9.9.ebuild20
-rw-r--r--app-emulation/wine/wine-9999.ebuild20
12 files changed, 132 insertions, 108 deletions
diff --git a/app-emulation/wine/wine-1.8-r1.ebuild b/app-emulation/wine/wine-1.8-r1.ebuild
index bdb29eb7b5d2..9819193fb67d 100644
--- a/app-emulation/wine/wine-1.8-r1.ebuild
+++ b/app-emulation/wine/wine-1.8-r1.ebuild
@@ -189,15 +189,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.8.1-r1.ebuild b/app-emulation/wine/wine-1.8.1-r1.ebuild
index f4681ee10299..693adfbcd889 100644
--- a/app-emulation/wine/wine-1.8.1-r1.ebuild
+++ b/app-emulation/wine/wine-1.8.1-r1.ebuild
@@ -190,15 +190,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.8.2.ebuild b/app-emulation/wine/wine-1.8.2.ebuild
index c3338f3da148..7b61b8599ef1 100644
--- a/app-emulation/wine/wine-1.8.2.ebuild
+++ b/app-emulation/wine/wine-1.8.2.ebuild
@@ -190,15 +190,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.10.ebuild b/app-emulation/wine/wine-1.9.10.ebuild
index 35f0ebff19f9..529dfbe03cd8 100644
--- a/app-emulation/wine/wine-1.9.10.ebuild
+++ b/app-emulation/wine/wine-1.9.10.ebuild
@@ -192,15 +192,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.11.ebuild b/app-emulation/wine/wine-1.9.11.ebuild
index 35f0ebff19f9..529dfbe03cd8 100644
--- a/app-emulation/wine/wine-1.9.11.ebuild
+++ b/app-emulation/wine/wine-1.9.11.ebuild
@@ -192,15 +192,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.4-r1.ebuild b/app-emulation/wine/wine-1.9.4-r1.ebuild
index 7c3d35a6fb07..44b40e1d16f9 100644
--- a/app-emulation/wine/wine-1.9.4-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.4-r1.ebuild
@@ -188,15 +188,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.5-r1.ebuild b/app-emulation/wine/wine-1.9.5-r1.ebuild
index 1634fd43e676..c42e24d6a34b 100644
--- a/app-emulation/wine/wine-1.9.5-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.5-r1.ebuild
@@ -187,15 +187,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.6-r1.ebuild b/app-emulation/wine/wine-1.9.6-r1.ebuild
index 618f4dd7d901..cab49fb06f34 100644
--- a/app-emulation/wine/wine-1.9.6-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.6-r1.ebuild
@@ -187,15 +187,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.7-r1.ebuild b/app-emulation/wine/wine-1.9.7-r1.ebuild
index 618f4dd7d901..cab49fb06f34 100644
--- a/app-emulation/wine/wine-1.9.7-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.7-r1.ebuild
@@ -187,15 +187,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.8.ebuild b/app-emulation/wine/wine-1.9.8.ebuild
index 8711bad95dff..7edb22948c86 100644
--- a/app-emulation/wine/wine-1.9.8.ebuild
+++ b/app-emulation/wine/wine-1.9.8.ebuild
@@ -187,15 +187,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-1.9.9.ebuild b/app-emulation/wine/wine-1.9.9.ebuild
index 35f0ebff19f9..529dfbe03cd8 100644
--- a/app-emulation/wine/wine-1.9.9.ebuild
+++ b/app-emulation/wine/wine-1.9.9.ebuild
@@ -192,15 +192,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 35f0ebff19f9..529dfbe03cd8 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -192,15 +192,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then