summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.8.1-r1.ebuild')
-rw-r--r--app-emulation/wine/wine-1.8.1-r1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-emulation/wine/wine-1.8.1-r1.ebuild b/app-emulation/wine/wine-1.8.1-r1.ebuild
index f4681ee10299..693adfbcd889 100644
--- a/app-emulation/wine/wine-1.8.1-r1.ebuild
+++ b/app-emulation/wine/wine-1.8.1-r1.ebuild
@@ -190,15 +190,17 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
- ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
- einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
- else
- eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
- eerror
- eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
- eerror
- return 1
+ if use abi_x86_64; then
+ einfo "Checking for builtin_ms_va_list ..."
+ if ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then