summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-15 03:27:57 +0000
committerSam James <sam@gentoo.org>2021-12-15 03:32:05 +0000
commit50507cc94f2a2b4536c742b7b183daf8b6e55231 (patch)
tree03cc2c74125f2a036cc65eb6699353902aaf8156 /sys-process
parentsys-devel/mold: update 9999 for tests (diff)
downloadgentoo-50507cc94f2a2b4536c742b7b183daf8b6e55231.tar.gz
gentoo-50507cc94f2a2b4536c742b7b183daf8b6e55231.tar.bz2
gentoo-50507cc94f2a2b4536c742b7b183daf8b6e55231.zip
sys-process/htop: fix automagic libunwind dependency
Maintainer timeout. Note that while libunwind is conditional, the functionality isn't: for musl, we're going to have to force USE=unwind (use libunwind or llvm-libunwind), while on glibc, it's fine to fallback to backtrace.h/execinfo (doesn't exist on musl). Closes: https://bugs.gentoo.org/818208 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/htop-3.1.2-r1.ebuild (renamed from sys-process/htop/htop-3.1.2.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-process/htop/htop-3.1.2.ebuild b/sys-process/htop/htop-3.1.2-r1.ebuild
index c11394f6a76a..138f07eb7bd5 100644
--- a/sys-process/htop/htop-3.1.2.ebuild
+++ b/sys-process/htop/htop-3.1.2-r1.ebuild
@@ -14,12 +14,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~
LICENSE="BSD GPL-2+"
SLOT="0"
-IUSE="caps debug delayacct hwloc kernel_FreeBSD kernel_linux lm-sensors openvz unicode vserver"
+IUSE="caps debug delayacct hwloc kernel_FreeBSD kernel_linux lm-sensors llvm-libunwind openvz unicode unwind vserver"
BDEPEND="virtual/pkgconfig"
RDEPEND="
sys-libs/ncurses:=[unicode(+)?]
hwloc? ( sys-apps/hwloc:= )
+ unwind? (
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ )
kernel_linux? (
caps? ( sys-libs/libcap )
delayacct? ( dev-libs/libnl:3 )
@@ -61,6 +65,7 @@ src_configure() {
$(use_enable !hwloc affinity)
$(use_enable openvz)
$(use_enable unicode)
+ $(use_enable unwind)
$(use_enable vserver)
)