summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/features/musl/package.use.force5
-rw-r--r--sys-process/htop/htop-3.1.2-r1.ebuild (renamed from sys-process/htop/htop-3.1.2.ebuild)7
2 files changed, 11 insertions, 1 deletions
diff --git a/profiles/features/musl/package.use.force b/profiles/features/musl/package.use.force
index da728fcc47ae..5495a35bbcbe 100644
--- a/profiles/features/musl/package.use.force
+++ b/profiles/features/musl/package.use.force
@@ -1,6 +1,11 @@
# Copyright 1999-2018 Gentoo Foundation.
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2021-12-15)
+# Force libunwind/llvm-libunwind (either way, a -lunwind) here as execinfo
+# isn't on musl. bug #818208.
+sys-process/htop unwind
+
# Andreas K. Hüttel <dilfridge@gentoo.org> (2021-07-14)
# Do not force system install for libxcrypt here
>=sys-libs/libxcrypt-4.4.23-r1 -system -compat
diff --git a/sys-process/htop/htop-3.1.2.ebuild b/sys-process/htop/htop-3.1.2-r1.ebuild
index c11394f6a76a..138f07eb7bd5 100644
--- a/sys-process/htop/htop-3.1.2.ebuild
+++ b/sys-process/htop/htop-3.1.2-r1.ebuild
@@ -14,12 +14,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~
LICENSE="BSD GPL-2+"
SLOT="0"
-IUSE="caps debug delayacct hwloc kernel_FreeBSD kernel_linux lm-sensors openvz unicode vserver"
+IUSE="caps debug delayacct hwloc kernel_FreeBSD kernel_linux lm-sensors llvm-libunwind openvz unicode unwind vserver"
BDEPEND="virtual/pkgconfig"
RDEPEND="
sys-libs/ncurses:=[unicode(+)?]
hwloc? ( sys-apps/hwloc:= )
+ unwind? (
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ )
kernel_linux? (
caps? ( sys-libs/libcap )
delayacct? ( dev-libs/libnl:3 )
@@ -61,6 +65,7 @@ src_configure() {
$(use_enable !hwloc affinity)
$(use_enable openvz)
$(use_enable unicode)
+ $(use_enable unwind)
$(use_enable vserver)
)