summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-30 01:36:55 +0100
committerSam James <sam@gentoo.org>2022-09-30 01:36:55 +0100
commit2e71b4c24f5fde61148a019004bbf01dcd6e277e (patch)
tree5c456c6dd1d46e0c946ab28a5d6252933e3c2413 /media-libs
parentmedia-gfx/blender: restrict tests for now (diff)
downloadgentoo-2e71b4c24f5fde61148a019004bbf01dcd6e277e.tar.gz
gentoo-2e71b4c24f5fde61148a019004bbf01dcd6e277e.tar.bz2
gentoo-2e71b4c24f5fde61148a019004bbf01dcd6e277e.zip
media-libs/stimg: fix configure with clang 16
Revbump for the jpeg dep. Closes: https://bugs.gentoo.org/871486 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/stimg/stimg-0.1.0-r1.ebuild (renamed from media-libs/stimg/stimg-0.1.0.ebuild)27
1 files changed, 19 insertions, 8 deletions
diff --git a/media-libs/stimg/stimg-0.1.0.ebuild b/media-libs/stimg/stimg-0.1.0-r1.ebuild
index 05c0e054bfcf..dd1d5aac1d48 100644
--- a/media-libs/stimg/stimg-0.1.0.ebuild
+++ b/media-libs/stimg/stimg-0.1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Simple and tiny image loading library"
HOMEPAGE="http://homepage3.nifty.com/slokar/fb/"
@@ -15,20 +15,31 @@ KEYWORDS="~alpha amd64 ppc x86"
RDEPEND="
media-libs/libpng:=
+ media-libs/libjpeg-turbo:=
media-libs/tiff:=
- virtual/jpeg"
+"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-libpng15.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-libpng15.patch
+)
+
+src_prepare() {
+ default
+
+ # bug #871486
+ eautoreconf
+}
src_configure() {
tc-export CC
- econf --disable-static
+
+ default
}
src_install() {
default
- # no static archives
- find "${D}" -name '*.la' -delete || die
+ # No static archives
+ find "${ED}" -name '*.la' -delete || die
}