summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pythong
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pythong')
-rw-r--r--dev-python/pythong/Manifest2
-rw-r--r--dev-python/pythong/metadata.xml5
-rw-r--r--dev-python/pythong/pythong-2.1.5-r2.ebuild56
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pythong/Manifest b/dev-python/pythong/Manifest
new file mode 100644
index 000000000000..596a041c5964
--- /dev/null
+++ b/dev-python/pythong/Manifest
@@ -0,0 +1,2 @@
+DIST python.pdf 2547987 SHA256 20e17f365b9f2c5ab0bed656a1ff8797b22b079a238a278674879b807bfd9dd4 SHA512 9d16eb39ff5996be70aa41cb758e73adf1fa72a7e83613626cf6f519def99fd30169a87b1e918902e1aecfb75d925cb7e49d9ad5733dd5274b9a351adaaf201e WHIRLPOOL 47fbcc853901e1df938e20fca1b18adca8985607d1edae60132b5b9490e8f6c1af39733186d079fac32e7e26a28bf7148062e108ad6c748dd110c2860520a49b
+DIST pythonG-2_1_5.tgz 397754 SHA256 6bc89217bfd89717eddd3b27682bb783446bcd3d87ed450e943e0369fa2c9243 SHA512 8a8c3ada425a1d7a0565e495494a8edfcf8b4224cb93ea843669e4d0b2ca9e122d038c728ff8242885e0b320caa6db8ef8f721f99c423b7a8f87a83a4e6f51c6 WHIRLPOOL 072f65639f5a371bf9a27885bc4f515e91f7abe0d6599457f167a7a81e493d8e12bc83d1520d5278421bc34bd1fd6c1c35d849dc653ea8754364c8c81528153e
diff --git a/dev-python/pythong/metadata.xml b/dev-python/pythong/metadata.xml
new file mode 100644
index 000000000000..ee7e8b2450a8
--- /dev/null
+++ b/dev-python/pythong/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pythong/pythong-2.1.5-r2.ebuild b/dev-python/pythong/pythong-2.1.5-r2.ebuild
new file mode 100644
index 000000000000..989a5417abaa
--- /dev/null
+++ b/dev-python/pythong/pythong-2.1.5-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1
+
+MY_PN="pythonG"
+MY_PV=${PV/_/-}
+MY_PV=${MY_PV//\./_}
+
+DESCRIPTION="Nice and powerful spanish development environment for Python"
+HOMEPAGE="http://www3.uji.es/~dllorens/PythonG/principal.html"
+SRC_URI="
+ http://www3.uji.es/~dllorens/downloads/pythong/linux/${MY_PN}-${MY_PV}.tgz
+ doc? ( http://marmota.act.uji.es/MTP/pdf/python.pdf )"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 x86"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-lang/tk-8.3.4:0=
+ virtual/pmw[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ sed \
+ -e "s:^\(fullpath = \).*:\1'$(python_get_sitedir)':" \
+ -e "/^url_docFuncPG/s:'+fullpath+':/usr/share/doc/${PF}:" \
+ -i pythong.py || die "sed in pythong.py failed"
+}
+
+src_install() {
+ python_domodule modulepythong.py libpythong
+ python_doscript pythong.py
+
+ dodoc leeme.txt
+ insinto /usr/share/doc/${PF}
+ doins -r {LICENCIA,MANUAL,demos}
+ rm -fr "${ED}/usr/share/doc/${PF}/demos/modulepythong.py" || die
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/python.pdf
+ fi
+ python_optimize
+}