summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 21:53:22 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 21:56:40 +0100
commit151ac3445e0de16cc02615d332980d865d8d19ae (patch)
treefcd01dfbdcba60625f86175ad3149687202a0446 /dev-python/cryptography
parentdev-python/PyQt5: Replace virts with cond deps (diff)
downloadgentoo-151ac3445e0de16cc02615d332980d865d8d19ae.tar.gz
gentoo-151ac3445e0de16cc02615d332980d865d8d19ae.tar.bz2
gentoo-151ac3445e0de16cc02615d332980d865d8d19ae.zip
dev-python/cryptography: Replace virts with cond deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/cryptography-2.6.1-r1.ebuild12
-rw-r--r--dev-python/cryptography/cryptography-2.8-r1.ebuild12
2 files changed, 16 insertions, 8 deletions
diff --git a/dev-python/cryptography/cryptography-2.6.1-r1.ebuild b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
index 1cfcb46fdc96..281e405e9f4e 100644
--- a/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
+++ b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
@@ -37,10 +37,14 @@ RDEPEND="
>=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '
+ dev-python/enum34[${PYTHON_USEDEP}]
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
+ !~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]
+ ' 'python*')
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
diff --git a/dev-python/cryptography/cryptography-2.8-r1.ebuild b/dev-python/cryptography/cryptography-2.8-r1.ebuild
index 7238fe0f9b47..2b7b392c0bd3 100644
--- a/dev-python/cryptography/cryptography-2.8-r1.ebuild
+++ b/dev-python/cryptography/cryptography-2.8-r1.ebuild
@@ -38,10 +38,14 @@ RDEPEND="
idna? ( >=dev-python/idna-2.1[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '
+ dev-python/enum34[${PYTHON_USEDEP}]
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
+ !~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]
+ ' 'python*')
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]