summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cryptography/cryptography-2.6.1-r1.ebuild')
-rw-r--r--dev-python/cryptography/cryptography-2.6.1-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/cryptography/cryptography-2.6.1-r1.ebuild b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
index 1cfcb46fdc96..281e405e9f4e 100644
--- a/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
+++ b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
@@ -37,10 +37,14 @@ RDEPEND="
>=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '
+ dev-python/enum34[${PYTHON_USEDEP}]
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
+ !~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]
+ ' 'python*')
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]