summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-09 08:02:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-09 09:09:36 +0100
commit5069e652b20d6373be051301d38a17d624dcf6cc (patch)
tree37ab8667ef4f2de107a3e088b2aad73381c7536e /dev-python/clang-python
parentdev-python/xcffib: Bump to 1.2.0 (diff)
downloadgentoo-5069e652b20d6373be051301d38a17d624dcf6cc.tar.gz
gentoo-5069e652b20d6373be051301d38a17d624dcf6cc.tar.bz2
gentoo-5069e652b20d6373be051301d38a17d624dcf6cc.zip
dev-python/clang-python: Disable default configs for tests
Disable default configs to resolve test failures due to unexpected input. Let's do it in ebuild until the problem is resolved upstream. Closes: https://bugs.gentoo.org/890204 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/clang-python-15.0.6.9999.ebuild3
-rw-r--r--dev-python/clang-python/clang-python-15.0.6.ebuild3
-rw-r--r--dev-python/clang-python/clang-python-16.0.0.9999.ebuild3
-rw-r--r--dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild1
4 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.6.9999.ebuild b/dev-python/clang-python/clang-python-15.0.6.9999.ebuild
index 9b34adc8ac6f..87e59ae7cd97 100644
--- a/dev-python/clang-python/clang-python-15.0.6.9999.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.6.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-15.0.6.ebuild b/dev-python/clang-python/clang-python-15.0.6.ebuild
index 4e6410cd2385..0e6fd91238ec 100644
--- a/dev-python/clang-python/clang-python-15.0.6.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
index 9b34adc8ac6f..87e59ae7cd97 100644
--- a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild b/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
index da0feef4cef2..87e59ae7cd97 100644
--- a/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}