summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/clang-python/clang-python-15.0.6.9999.ebuild3
-rw-r--r--dev-python/clang-python/clang-python-15.0.6.ebuild3
-rw-r--r--dev-python/clang-python/clang-python-16.0.0.9999.ebuild3
-rw-r--r--dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild1
4 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.6.9999.ebuild b/dev-python/clang-python/clang-python-15.0.6.9999.ebuild
index 9b34adc8ac6f..87e59ae7cd97 100644
--- a/dev-python/clang-python/clang-python-15.0.6.9999.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.6.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-15.0.6.ebuild b/dev-python/clang-python/clang-python-15.0.6.ebuild
index 4e6410cd2385..0e6fd91238ec 100644
--- a/dev-python/clang-python/clang-python-15.0.6.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
index 9b34adc8ac6f..87e59ae7cd97 100644
--- a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild b/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
index da0feef4cef2..87e59ae7cd97 100644
--- a/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
@@ -41,6 +41,7 @@ python_test() {
# tests rely on results from a specific clang version, so override
# the search path
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}