aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPureTryOut <bribbers@disroot.org>2019-01-09 02:08:10 +0100
committerPureTryOut <bribbers@disroot.org>2019-01-09 02:08:10 +0100
commit02e3baf5dcf20d396430bb15da23ae0a3aab82de (patch)
tree466034614f172339bfb7a5d91fc85a2fa5d45dec /dev-libs
parentnet-im/nheko & dev-libs/mtxclient: remove as they have been unmaintained for ... (diff)
downloadmatrix-02e3baf5dcf20d396430bb15da23ae0a3aab82de.tar.gz
matrix-02e3baf5dcf20d396430bb15da23ae0a3aab82de.tar.bz2
matrix-02e3baf5dcf20d396430bb15da23ae0a3aab82de.zip
net-im/fractal: update to 4.0.0 and update packaging
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libhandy/Manifest4
-rw-r--r--dev-libs/libhandy/files/g-enum-no-auto-ptr.patch21
-rw-r--r--dev-libs/libhandy/libhandy-0.0.6.ebuild44
-rw-r--r--dev-libs/libhandy/libhandy-9999.ebuild45
-rw-r--r--dev-libs/sortfilterproxymodel/Manifest2
5 files changed, 115 insertions, 1 deletions
diff --git a/dev-libs/libhandy/Manifest b/dev-libs/libhandy/Manifest
new file mode 100644
index 0000000..b958802
--- /dev/null
+++ b/dev-libs/libhandy/Manifest
@@ -0,0 +1,4 @@
+AUX g-enum-no-auto-ptr.patch 1001 BLAKE2B 2f7a1c8b05336ad70677d195f0a4942e7b8398190020ea3d62b01f35b802ff4a5941eb41dda4a0a4c545beeb6f30404262acda6a6e6757052091271de782dd17 SHA512 2727c31ae34b41976b9a00d46cf59180aaa03ac028b4a3ae194f342030311dfe1d4520009dae7a86765366882ec6f7e3c553d7cf5edcbd8fa80355ca5db1313b
+DIST libhandy-0.0.6.tar.gz 123445 BLAKE2B dcfd44586533a56ae61e433783051ae0eddd0d4f2d7c33d6b7296d845bfe0fe66635e95ba83abd474aa2f5ed539626ac99cd0e81ae608213f03b65792312680a SHA512 7a474d081827c2cd21f069547c1285139e73976052e310b0ef4cbf3a4aa5a89d959b6dd39e690c1f6a79e7a0a72789199b2f907f694078e20219a0f6f91ca981
+EBUILD libhandy-0.0.6.ebuild 895 BLAKE2B 9d7cac559fee36f7dade9f90f9d6ea745e36ecceca11bf07aadb5820f4f419c33af11888a3815e087d2632f894cf65634b961f39a90e5237cbedbb368898e6c2 SHA512 0f33dd72579a31eaccdcd7485f2477aab4874414a41524ea0848ed5d8c2cd2c48acc8c7fd172ed01f61c065fe1c231a35492e2bc51616a121a05391217339185
+EBUILD libhandy-9999.ebuild 935 BLAKE2B 7607846910a378440ed3ffff0a4a17780beac9cf265952b8d6cb6ba84a0221805e9f1e61e759e0806477e8353742ac971f903ff39750d04a480f9e9752b877e4 SHA512 797b5e4548870ce71100cc47c2bd3b8dfda8dab48c68e627384cbec39a4bdd4e91584a2ddeaea70dbc65a2debbfa98a9b34193b3d5138267a90a0258c1cd88a3
diff --git a/dev-libs/libhandy/files/g-enum-no-auto-ptr.patch b/dev-libs/libhandy/files/g-enum-no-auto-ptr.patch
new file mode 100644
index 0000000..cb796b7
--- /dev/null
+++ b/dev-libs/libhandy/files/g-enum-no-auto-ptr.patch
@@ -0,0 +1,21 @@
+diff --git a/src/hdy-combo-row.c b/src/hdy-combo-row.c
+index 633dd7d00e16fc8581823ecc501e53b0908c2ca6..b221c220a95ea0ff5d365b0e9df396962d2ffc74 100644
+--- a/src/hdy-combo-row.c
++++ b/src/hdy-combo-row.c
+@@ -479,7 +479,7 @@ hdy_combo_row_set_for_enum (HdyComboRow *self,
+ GDestroyNotify user_data_free_func)
+ {
+ g_autoptr (GListStore) store = g_list_store_new (HDY_TYPE_ENUM_VALUE_OBJECT);
+- g_autoptr (GEnumClass) enum_class = g_type_class_ref (enum_type);
++ GEnumClass *enum_class = g_type_class_ref (enum_type);
+ gsize i;
+
+ g_return_if_fail (HDY_IS_COMBO_ROW (self));
+@@ -488,6 +488,7 @@ hdy_combo_row_set_for_enum (HdyComboRow *self,
+ g_list_store_append (store, hdy_enum_value_object_new (&enum_class->values[i]));
+
+ hdy_combo_row_bind_name_model (self, G_LIST_MODEL (store), (HdyComboRowGetNameFunc) get_name_func, user_data, user_data_free_func);
++ g_type_class_unref (enum_class);
+ }
+
+ /**
diff --git a/dev-libs/libhandy/libhandy-0.0.6.ebuild b/dev-libs/libhandy/libhandy-0.0.6.ebuild
new file mode 100644
index 0000000..f694b6b
--- /dev/null
+++ b/dev-libs/libhandy/libhandy-0.0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson vala
+
+DESCRIPTION="A library full of GTK+ widgets for mobile phones"
+HOMEPAGE="https://source.puri.sm/Librem5/libhandy"
+
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://source.puri.sm/Librem5/${PN}.git"
+else
+ SRC_URI="https://source.puri.sm/Librem5/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ PATCHES=("${FILESDIR}/g-enum-no-auto-ptr.patch")
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/meson
+ dev-lang/vala
+ dev-util/glade
+ dev-libs/gobject-introspection
+ gnome-base/gnome-desktop"
+
+VALA_USE_DEPEND=vapigen
+BUILD_DIR="${S}/build"
+
+src_prepare() {
+ default
+
+ vala_src_prepare --vala-api-version $(vala_best_api_version)
+}
diff --git a/dev-libs/libhandy/libhandy-9999.ebuild b/dev-libs/libhandy/libhandy-9999.ebuild
new file mode 100644
index 0000000..bb69399
--- /dev/null
+++ b/dev-libs/libhandy/libhandy-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson vala
+
+DESCRIPTION="A library full of GTK+ widgets for mobile phones"
+HOMEPAGE="https://source.puri.sm/Librem5/libhandy"
+
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://source.puri.sm/guido.gunther/${PN}.git"
+ EGIT_BRANCH="g-enum-no-auto-ptr"
+else
+ SRC_URI="https://source.puri.sm/Librem5/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ PATCHES=("${FILESDIR}/g-enum-no-auto-ptr.patch")
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/meson
+ dev-lang/vala
+ dev-util/glade
+ dev-libs/gobject-introspection
+ gnome-base/gnome-desktop"
+
+VALA_USE_DEPEND=vapigen
+BUILD_DIR="${S}/build"
+
+src_prepare() {
+ default
+
+ vala_src_prepare --vala-api-version $(vala_best_api_version)
+}
diff --git a/dev-libs/sortfilterproxymodel/Manifest b/dev-libs/sortfilterproxymodel/Manifest
index 46a42b6..e6e217e 100644
--- a/dev-libs/sortfilterproxymodel/Manifest
+++ b/dev-libs/sortfilterproxymodel/Manifest
@@ -1 +1 @@
-EBUILD sortfilterproxymodel-9999.ebuild 676 BLAKE2B d17c7077ed4c0e03f5f0b7faac53a4e7ddccce993c690fac6ccaa46fb9929604d5c802b2f0426ef9e573eb274f2e361fd820570cca0b964bfc751d34484e147b SHA512 bdd5750780f4ba081c5b1cec021f2e1a4a594eeec4af4f1430bc7fe99ede6e50f96b452aa9a2a5aba00f1cb3a790e180c5770860dca39df423ff09e2693067ed
+EBUILD sortfilterproxymodel-9999.ebuild 720 BLAKE2B 21cb652192417a8e5356d3a4b559fc173fb2a4849a8fd3dbdab80cb9fbfc5cee0aa26da5eccdc25105e42a0da26ee724b836dba562ead3c6e2536c9d4cb6f23f SHA512 cb39caaa154a9188ec304f723e8a8cd7b8789dfc7d2469d52d8b367c9564de790b4f58e2a9f410ef9f2f9bc2a096e85969e30f173cf77633f49f35ec7570a829