aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libhandy/Manifest4
-rw-r--r--dev-libs/libhandy/files/g-enum-no-auto-ptr.patch21
-rw-r--r--dev-libs/libhandy/libhandy-0.0.6.ebuild44
-rw-r--r--dev-libs/libhandy/libhandy-9999.ebuild45
-rw-r--r--dev-libs/sortfilterproxymodel/Manifest2
-rw-r--r--net-im/fractal/Manifest9
-rw-r--r--net-im/fractal/fractal-3.29.1.ebuild37
-rw-r--r--net-im/fractal/fractal-3.29.6-r1.ebuild (renamed from net-im/fractal/fractal-3.29.6.ebuild)24
-rw-r--r--net-im/fractal/fractal-4.0.0.ebuild33
-rw-r--r--net-im/fractal/fractal-9999.ebuild33
10 files changed, 171 insertions, 81 deletions
diff --git a/dev-libs/libhandy/Manifest b/dev-libs/libhandy/Manifest
new file mode 100644
index 0000000..b958802
--- /dev/null
+++ b/dev-libs/libhandy/Manifest
@@ -0,0 +1,4 @@
+AUX g-enum-no-auto-ptr.patch 1001 BLAKE2B 2f7a1c8b05336ad70677d195f0a4942e7b8398190020ea3d62b01f35b802ff4a5941eb41dda4a0a4c545beeb6f30404262acda6a6e6757052091271de782dd17 SHA512 2727c31ae34b41976b9a00d46cf59180aaa03ac028b4a3ae194f342030311dfe1d4520009dae7a86765366882ec6f7e3c553d7cf5edcbd8fa80355ca5db1313b
+DIST libhandy-0.0.6.tar.gz 123445 BLAKE2B dcfd44586533a56ae61e433783051ae0eddd0d4f2d7c33d6b7296d845bfe0fe66635e95ba83abd474aa2f5ed539626ac99cd0e81ae608213f03b65792312680a SHA512 7a474d081827c2cd21f069547c1285139e73976052e310b0ef4cbf3a4aa5a89d959b6dd39e690c1f6a79e7a0a72789199b2f907f694078e20219a0f6f91ca981
+EBUILD libhandy-0.0.6.ebuild 895 BLAKE2B 9d7cac559fee36f7dade9f90f9d6ea745e36ecceca11bf07aadb5820f4f419c33af11888a3815e087d2632f894cf65634b961f39a90e5237cbedbb368898e6c2 SHA512 0f33dd72579a31eaccdcd7485f2477aab4874414a41524ea0848ed5d8c2cd2c48acc8c7fd172ed01f61c065fe1c231a35492e2bc51616a121a05391217339185
+EBUILD libhandy-9999.ebuild 935 BLAKE2B 7607846910a378440ed3ffff0a4a17780beac9cf265952b8d6cb6ba84a0221805e9f1e61e759e0806477e8353742ac971f903ff39750d04a480f9e9752b877e4 SHA512 797b5e4548870ce71100cc47c2bd3b8dfda8dab48c68e627384cbec39a4bdd4e91584a2ddeaea70dbc65a2debbfa98a9b34193b3d5138267a90a0258c1cd88a3
diff --git a/dev-libs/libhandy/files/g-enum-no-auto-ptr.patch b/dev-libs/libhandy/files/g-enum-no-auto-ptr.patch
new file mode 100644
index 0000000..cb796b7
--- /dev/null
+++ b/dev-libs/libhandy/files/g-enum-no-auto-ptr.patch
@@ -0,0 +1,21 @@
+diff --git a/src/hdy-combo-row.c b/src/hdy-combo-row.c
+index 633dd7d00e16fc8581823ecc501e53b0908c2ca6..b221c220a95ea0ff5d365b0e9df396962d2ffc74 100644
+--- a/src/hdy-combo-row.c
++++ b/src/hdy-combo-row.c
+@@ -479,7 +479,7 @@ hdy_combo_row_set_for_enum (HdyComboRow *self,
+ GDestroyNotify user_data_free_func)
+ {
+ g_autoptr (GListStore) store = g_list_store_new (HDY_TYPE_ENUM_VALUE_OBJECT);
+- g_autoptr (GEnumClass) enum_class = g_type_class_ref (enum_type);
++ GEnumClass *enum_class = g_type_class_ref (enum_type);
+ gsize i;
+
+ g_return_if_fail (HDY_IS_COMBO_ROW (self));
+@@ -488,6 +488,7 @@ hdy_combo_row_set_for_enum (HdyComboRow *self,
+ g_list_store_append (store, hdy_enum_value_object_new (&enum_class->values[i]));
+
+ hdy_combo_row_bind_name_model (self, G_LIST_MODEL (store), (HdyComboRowGetNameFunc) get_name_func, user_data, user_data_free_func);
++ g_type_class_unref (enum_class);
+ }
+
+ /**
diff --git a/dev-libs/libhandy/libhandy-0.0.6.ebuild b/dev-libs/libhandy/libhandy-0.0.6.ebuild
new file mode 100644
index 0000000..f694b6b
--- /dev/null
+++ b/dev-libs/libhandy/libhandy-0.0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson vala
+
+DESCRIPTION="A library full of GTK+ widgets for mobile phones"
+HOMEPAGE="https://source.puri.sm/Librem5/libhandy"
+
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://source.puri.sm/Librem5/${PN}.git"
+else
+ SRC_URI="https://source.puri.sm/Librem5/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ PATCHES=("${FILESDIR}/g-enum-no-auto-ptr.patch")
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/meson
+ dev-lang/vala
+ dev-util/glade
+ dev-libs/gobject-introspection
+ gnome-base/gnome-desktop"
+
+VALA_USE_DEPEND=vapigen
+BUILD_DIR="${S}/build"
+
+src_prepare() {
+ default
+
+ vala_src_prepare --vala-api-version $(vala_best_api_version)
+}
diff --git a/dev-libs/libhandy/libhandy-9999.ebuild b/dev-libs/libhandy/libhandy-9999.ebuild
new file mode 100644
index 0000000..bb69399
--- /dev/null
+++ b/dev-libs/libhandy/libhandy-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson vala
+
+DESCRIPTION="A library full of GTK+ widgets for mobile phones"
+HOMEPAGE="https://source.puri.sm/Librem5/libhandy"
+
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://source.puri.sm/guido.gunther/${PN}.git"
+ EGIT_BRANCH="g-enum-no-auto-ptr"
+else
+ SRC_URI="https://source.puri.sm/Librem5/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ PATCHES=("${FILESDIR}/g-enum-no-auto-ptr.patch")
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/meson
+ dev-lang/vala
+ dev-util/glade
+ dev-libs/gobject-introspection
+ gnome-base/gnome-desktop"
+
+VALA_USE_DEPEND=vapigen
+BUILD_DIR="${S}/build"
+
+src_prepare() {
+ default
+
+ vala_src_prepare --vala-api-version $(vala_best_api_version)
+}
diff --git a/dev-libs/sortfilterproxymodel/Manifest b/dev-libs/sortfilterproxymodel/Manifest
index 46a42b6..e6e217e 100644
--- a/dev-libs/sortfilterproxymodel/Manifest
+++ b/dev-libs/sortfilterproxymodel/Manifest
@@ -1 +1 @@
-EBUILD sortfilterproxymodel-9999.ebuild 676 BLAKE2B d17c7077ed4c0e03f5f0b7faac53a4e7ddccce993c690fac6ccaa46fb9929604d5c802b2f0426ef9e573eb274f2e361fd820570cca0b964bfc751d34484e147b SHA512 bdd5750780f4ba081c5b1cec021f2e1a4a594eeec4af4f1430bc7fe99ede6e50f96b452aa9a2a5aba00f1cb3a790e180c5770860dca39df423ff09e2693067ed
+EBUILD sortfilterproxymodel-9999.ebuild 720 BLAKE2B 21cb652192417a8e5356d3a4b559fc173fb2a4849a8fd3dbdab80cb9fbfc5cee0aa26da5eccdc25105e42a0da26ee724b836dba562ead3c6e2536c9d4cb6f23f SHA512 cb39caaa154a9188ec304f723e8a8cd7b8789dfc7d2469d52d8b367c9564de790b4f58e2a9f410ef9f2f9bc2a096e85969e30f173cf77633f49f35ec7570a829
diff --git a/net-im/fractal/Manifest b/net-im/fractal/Manifest
index 7e00227..6a23fa1 100644
--- a/net-im/fractal/Manifest
+++ b/net-im/fractal/Manifest
@@ -1,4 +1,5 @@
-DIST fractal-3.29.6.tar.xz 11575244 BLAKE2B 17045140a09bf1a999eafb139dc89d19f8be14f38b7ee794fd297c144e11e88c5e9414fad6dcf6c3cba066ff5b62b230ceb69e2494992e352cd013abbe8ee6da SHA512 d49df43b79b3f5dca64cc0e80422593f913408418a52d4cb726afaa7c457992a6eca55ce29de3bb3c7cea5576e8068a5d3422a84bf02f39f791fd6056fdce85e
-EBUILD fractal-3.29.1.ebuild 716 BLAKE2B 32f528bb398a51c660eae5242ca39157b2e2f531deebf0707625e9df775a1fc3f0d4d9f6bf27b3c2c73b2add66ad76df52ebc0d98d1a67bb229ec8531c4e8296 SHA512 bda4f3e22871204dd637ca5a0b7a3e1583a734441c3943dab02a6896e1287b1641093e5e2a8b09d731e7c115e0176462821469b63eb97475b77daf00a7d748a1
-EBUILD fractal-3.29.6.ebuild 848 BLAKE2B c0454c87586d0b638fa715795bdf093f14e7479611f3db1b0decb3779d838db57dd021a4839019704f730d6a0eefe31dbb49f3efc25433abb938f0b6071604b6 SHA512 d16645768cf1435f735bf509ff2ac6cdad5a33e6f377f7513cfae74e06392f11ddb57d4dc3b47df524bdd3cf9af337d80b1389b0812278a4c47ca6a6b583c4f1
-EBUILD fractal-9999.ebuild 848 BLAKE2B c0454c87586d0b638fa715795bdf093f14e7479611f3db1b0decb3779d838db57dd021a4839019704f730d6a0eefe31dbb49f3efc25433abb938f0b6071604b6 SHA512 d16645768cf1435f735bf509ff2ac6cdad5a33e6f377f7513cfae74e06392f11ddb57d4dc3b47df524bdd3cf9af337d80b1389b0812278a4c47ca6a6b583c4f1
+DIST fractal-3.29.6.tar.gz 522007 BLAKE2B 6ede6b408714fe5d7c7a9a80e9b2c38cd603d1439675be4b72401659a1f2bf652010775182fc24a6491d4906c59d1dee2397ca66e16c83071a96d2cae9cd5dbf SHA512 f7efdf70b793bd25852a5071f685a07126f206b74267d65c42e070c7e916acaffb8ab3ccd85f1153d59432cae07c15e487a811558fb8c7a5fbf2f180683442bb
+DIST fractal-4.0.0.tar.gz 714590 BLAKE2B 9dad4d4dfa56e65f887917f6e5c76c35bf7de2825c72cd13f38c9da207b51b87a3ff608ae6f7c5c49af9881e2a42a828c36c9dd740dcb2ca49cdec65fdad9bdd SHA512 91aef68d8d7024e27c0448854dfcefd04a6f7757e5cd649659edbeb59ba5d508879102926ad008dc65d2f2dbef2a39528375a1c02f82b7a18eee322cfbd28d40
+EBUILD fractal-3.29.6-r1.ebuild 625 BLAKE2B 7b430ca1ec91ec32702918d5fe557d2fe3ae5568ece11de6804127ae52983c85f120ae19b08a681158ef770555e79df27c1342dfcf8bb37fbbca1f0669bac05d SHA512 57291097125563442c71b0a4d00bb3230df0af9652b22ed79ab0d2617e338527a4f406891e3fce001a802f01652fd7902a5ade796657bb27e055e361b1e273cb
+EBUILD fractal-4.0.0.ebuild 702 BLAKE2B f4c0639bc1fb3523ff6ab919d9ce594cc5f2473a648a3cd3944dfb660876ca0c0382e94b6766380e846222793a545ff3d5cf2bd0dd6ea50711fab7f00fb139f0 SHA512 c84d5872a3cc7de2abd64faf94377e8bb330352330d993667a2f1a32e8785547dd422e86ebafd32b96a3f49159feea493925f30fd20c1ae11859065417488987
+EBUILD fractal-9999.ebuild 702 BLAKE2B f4c0639bc1fb3523ff6ab919d9ce594cc5f2473a648a3cd3944dfb660876ca0c0382e94b6766380e846222793a545ff3d5cf2bd0dd6ea50711fab7f00fb139f0 SHA512 c84d5872a3cc7de2abd64faf94377e8bb330352330d993667a2f1a32e8785547dd422e86ebafd32b96a3f49159feea493925f30fd20c1ae11859065417488987
diff --git a/net-im/fractal/fractal-3.29.1.ebuild b/net-im/fractal/fractal-3.29.1.ebuild
deleted file mode 100644
index 26a1cf2..0000000
--- a/net-im/fractal/fractal-3.29.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Matrix group messaging app"
-HOMEPAGE="https://wiki.gnome.org/Apps/Fractal"
-
-inherit git-r3 meson xdg-utils gnome2-utils
-
-EGIT_REPO_URI="https://gitlab.gnome.org/world/fractal.git"
-if [[ ${PV} != "9999" ]]; then
- EGIT_COMMIT="${PV}"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-lang/rust
- >=app-text/gspell-1.8.1"
-DEPEND="${RDEPEND}
- dev-util/ninja
- dev-util/meson
- dev-util/ninja
- dev-util/cargo"
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-im/fractal/fractal-3.29.6.ebuild b/net-im/fractal/fractal-3.29.6-r1.ebuild
index 41749d4..153f099 100644
--- a/net-im/fractal/fractal-3.29.6.ebuild
+++ b/net-im/fractal/fractal-3.29.6-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Matrix group messaging app"
HOMEPAGE="https://wiki.gnome.org/Apps/Fractal"
-inherit meson xdg-utils gnome2-utils
+inherit meson xdg-utils
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -15,7 +15,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://gitlab.gnome.org/world/fractal.git"
EGIT_BRANCH="master"
else
- SRC_URI="https://gitlab.gnome.org/World/fractal/uploads/bd30b8084b5f15c47d9fdc3049fe0515/${P}.tar.xz"
+ SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,18 +25,6 @@ IUSE=""
RDEPEND="dev-lang/rust
>=app-text/gspell-1.8.1"
-DEPEND="${RDEPEND}
- dev-util/ninja
- dev-util/meson
- dev-util/ninja
- dev-util/cargo"
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/ninja
+ dev-util/meson"
diff --git a/net-im/fractal/fractal-4.0.0.ebuild b/net-im/fractal/fractal-4.0.0.ebuild
new file mode 100644
index 0000000..a2b7a8c
--- /dev/null
+++ b/net-im/fractal/fractal-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Matrix group messaging app"
+HOMEPAGE="https://wiki.gnome.org/Apps/Fractal"
+
+inherit meson xdg-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://gitlab.gnome.org/world/fractal.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+ #KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=virtual/rust-1.31.1
+ >=app-text/gspell-1.8.1
+ >=x11-libs/cairo-1.16.0
+ x11-libs/gtksourceview
+ dev-libs/libhandy"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/ninja
+ dev-util/meson"
diff --git a/net-im/fractal/fractal-9999.ebuild b/net-im/fractal/fractal-9999.ebuild
index 41749d4..a2b7a8c 100644
--- a/net-im/fractal/fractal-9999.ebuild
+++ b/net-im/fractal/fractal-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Matrix group messaging app"
HOMEPAGE="https://wiki.gnome.org/Apps/Fractal"
-inherit meson xdg-utils gnome2-utils
+inherit meson xdg-utils
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -15,28 +15,19 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://gitlab.gnome.org/world/fractal.git"
EGIT_BRANCH="master"
else
- SRC_URI="https://gitlab.gnome.org/World/fractal/uploads/bd30b8084b5f15c47d9fdc3049fe0515/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+ #KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3"
SLOT="0"
IUSE=""
-RDEPEND="dev-lang/rust
- >=app-text/gspell-1.8.1"
-DEPEND="${RDEPEND}
- dev-util/ninja
- dev-util/meson
- dev-util/ninja
- dev-util/cargo"
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
+RDEPEND=">=virtual/rust-1.31.1
+ >=app-text/gspell-1.8.1
+ >=x11-libs/cairo-1.16.0
+ x11-libs/gtksourceview
+ dev-libs/libhandy"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/ninja
+ dev-util/meson"