aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-02-19 20:26:46 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-02-19 21:41:49 +0900
commit65bccbe06364a76cda7590425dd2d6481d61423a (patch)
tree078c98bc2159d392c488315a60b4e155224abe38 /gnome-extra
parentgui-apps/ReGreet: drop 0.1.1-r4, add 0.1.1-r5 (diff)
downloadguru-65bccbe06364a76cda7590425dd2d6481d61423a.tar.gz
guru-65bccbe06364a76cda7590425dd2d6481d61423a.tar.bz2
guru-65bccbe06364a76cda7590425dd2d6481d61423a.zip
gnome-extra/yad: add 13.0
Closes: https://bugs.gentoo.org/921917 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/yad/Manifest1
-rw-r--r--gnome-extra/yad/metadata.xml1
-rw-r--r--gnome-extra/yad/yad-13.0.ebuild36
3 files changed, 38 insertions, 0 deletions
diff --git a/gnome-extra/yad/Manifest b/gnome-extra/yad/Manifest
index abec8d94c..09cb79d1b 100644
--- a/gnome-extra/yad/Manifest
+++ b/gnome-extra/yad/Manifest
@@ -1 +1,2 @@
DIST yad-10.1.tar.xz 290776 BLAKE2B 05801869314752b443beac56527909cf4ed3047bdcc3531d27a038ca866f1ae2c43dbc7c10c38829c6ec3cfa7b87158de800d833a3d7c2ac834cbfb9f7ebaa89 SHA512 2e55779074c64da679eab03c4e5d655470293d9fd7c7e7bc0e653610d5952f37cb96829185fab84471a8fe833f0a9fb2daef18f2ab2936acc1e141d8166a7355
+DIST yad-13.0.tar.xz 298092 BLAKE2B b07e796109daf27471ad74dae91637a297b6a830a7ea5f5386f7c9c4c4effdbc794b92e7e747adb5f0df80540b2fe75ae87856f695d4f578aa5cfbd6ea4b42ab SHA512 89f438a49722b9aa63ec942a200b4684f88e0e2b489b77b909c03208af644c46d22601a072bcbad1c36707013ee308417d73ce08f2494b8962bce9bf06d58a16
diff --git a/gnome-extra/yad/metadata.xml b/gnome-extra/yad/metadata.xml
index 900ce7ced..13856c99f 100644
--- a/gnome-extra/yad/metadata.xml
+++ b/gnome-extra/yad/metadata.xml
@@ -15,6 +15,7 @@
<remote-id type="github">v1cont/yad</remote-id>
</upstream>
<use>
+ <flag name="sourceview">Enable GtkSourceView support with <pkg>x11-libs/gtksourceview</pkg></flag>
<flag name="spell">Enable spell check support with <pkg>app-text/gspell</pkg></flag>
</use>
</pkgmetadata>
diff --git a/gnome-extra/yad/yad-13.0.ebuild b/gnome-extra/yad/yad-13.0.ebuild
new file mode 100644
index 000000000..35a88eb3c
--- /dev/null
+++ b/gnome-extra/yad/yad-13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Display GTK+ dialog boxes from command line or shell scripts"
+HOMEPAGE="https://github.com/v1cont/yad"
+SRC_URI="https://github.com/v1cont/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nls sourceview spell webkit"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ sourceview? ( x11-libs/gtksourceview:3.0= )
+ spell? ( app-text/gspell:= )
+ webkit? ( net-libs/webkit-gtk:4= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-util/intltool-0.40"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable sourceview) \
+ $(use_enable spell) \
+ $(use_enable webkit html) \
+ --disable-standalone \
+ --enable-icon-browser \
+ --enable-tools \
+ --enable-tray
+}