aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/yad/yad-13.0.ebuild')
-rw-r--r--gnome-extra/yad/yad-13.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnome-extra/yad/yad-13.0.ebuild b/gnome-extra/yad/yad-13.0.ebuild
new file mode 100644
index 000000000..35a88eb3c
--- /dev/null
+++ b/gnome-extra/yad/yad-13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Display GTK+ dialog boxes from command line or shell scripts"
+HOMEPAGE="https://github.com/v1cont/yad"
+SRC_URI="https://github.com/v1cont/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nls sourceview spell webkit"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ sourceview? ( x11-libs/gtksourceview:3.0= )
+ spell? ( app-text/gspell:= )
+ webkit? ( net-libs/webkit-gtk:4= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-util/intltool-0.40"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable sourceview) \
+ $(use_enable spell) \
+ $(use_enable webkit html) \
+ --disable-standalone \
+ --enable-icon-browser \
+ --enable-tools \
+ --enable-tray
+}