summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-environment')
-rw-r--r--dev-lisp/cl-environment/ChangeLog10
-rw-r--r--dev-lisp/cl-environment/Manifest5
-rw-r--r--dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild28
-rw-r--r--dev-lisp/cl-environment/files/digest-cl-environment-1.0.200211051
-rw-r--r--dev-lisp/cl-environment/files/environment.asd48
-rw-r--r--dev-lisp/cl-environment/metadata.xml5
6 files changed, 97 insertions, 0 deletions
diff --git a/dev-lisp/cl-environment/ChangeLog b/dev-lisp/cl-environment/ChangeLog
new file mode 100644
index 000000000000..dc3340bae383
--- /dev/null
+++ b/dev-lisp/cl-environment/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-environment
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-environment/ChangeLog,v 1.1 2004/05/14 19:12:51 mkennedy Exp $
+
+*cl-environment-1.0.20021105 (14 May 2004)
+
+ 14 May 2004; <mkennedy@gentoo.org> +metadata.xml, +files/environment.asd,
+ +cl-environment-1.0.20021105.ebuild:
+ Initial port. Ebuild contrtibuted by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-environment/Manifest b/dev-lisp/cl-environment/Manifest
new file mode 100644
index 000000000000..66c323f61152
--- /dev/null
+++ b/dev-lisp/cl-environment/Manifest
@@ -0,0 +1,5 @@
+MD5 aa5352853d86acf484aaee65311b3cd6 cl-environment-1.0.20021105.ebuild 897
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 05e72a8111a6f66eab3625d17fde4601 cl-environment-1.0.20021105.ebuild~ 1131
+MD5 73628f45cae318422a472eb337abe3e8 files/environment.asd 1238
+MD5 7561d19de11e63e592d89932e7267ded files/digest-cl-environment-1.0.20021105 89
diff --git a/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild b/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild
new file mode 100644
index 000000000000..20981a6f91b8
--- /dev/null
+++ b/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild,v 1.1 2004/05/14 19:12:51 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:3}
+CVS_PV=${PV:4:4}.${PV:8:2}.${PV:10}
+
+DESCRIPTION="Provides an CLOS (CL Object System) encapsulation of the current CL implementation environment"
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-environment"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-environment/cl-environment_${MY_PV}+cvs.${CVS_PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=environment
+
+S=${WORKDIR}/cl-environment-${MY_PV}+cvs.${CVS_PV}
+
+src_install() {
+ common-lisp-install *.lisp ${FILESDIR}/environment.asd
+ insinto ${CLSOURCEROOT}/${CLPACKAGE}/impl-dependent; doins impl-dependent/*.lisp
+ common-lisp-system-symlink
+ dodoc COPYING INSTALLATION README
+}
diff --git a/dev-lisp/cl-environment/files/digest-cl-environment-1.0.20021105 b/dev-lisp/cl-environment/files/digest-cl-environment-1.0.20021105
new file mode 100644
index 000000000000..464d78f1abdd
--- /dev/null
+++ b/dev-lisp/cl-environment/files/digest-cl-environment-1.0.20021105
@@ -0,0 +1 @@
+MD5 14c3ad229221144cb45bdeb327a522ca cl-environment_1.0+cvs.2002.11.05.orig.tar.gz 21029
diff --git a/dev-lisp/cl-environment/files/environment.asd b/dev-lisp/cl-environment/files/environment.asd
new file mode 100644
index 000000000000..deb6425e37dd
--- /dev/null
+++ b/dev-lisp/cl-environment/files/environment.asd
@@ -0,0 +1,48 @@
+;;;; -*- Mode: Lisp -*-
+
+;;;; This file is from Debian. Copyright Kevin M. Rosenberg <kmr@debian.org>
+
+(in-package :asdf)
+
+(defsystem :environment
+ :perform (load-op :after (op environment)
+ (pushnew :environment cl:*features*))
+ :components
+ ((:file "env-package")
+ (:file "feature-tagged-type-class" :depends-on ("env-package"))
+ (:file "software"
+ :depends-on ("env-package"
+ "feature-tagged-type-class"))
+ (:file "machine"
+ :depends-on ("env-package"
+ "feature-tagged-type-class"))
+ (:file "operating-system"
+ :depends-on ("software"))
+ (:file "environment"
+ :depends-on ("operating-system" "machine"))
+ (:file "init-environment"
+ :depends-on ("environment"
+ "software"
+ "operating-system"
+ "machine"
+ ))
+ (:module impl-dependent
+ :depends-on ("init-environment")
+ :components
+ ((:file
+ #+clisp "clisp"
+ #+lispworks "lispworks"
+ #+allegro "allegro"
+ #+cmu "cmucl"
+ #+sbcl "sbcl"
+ #+scl "scl"
+ #+openmcl "openmcl"
+ #+lcl "lcl"
+ #+cormanlisp "corman"
+ )))
+
+ (:file "system-info"
+ :depends-on ("impl-dependent" "utilities"))
+ (:file "utilities"
+ :depends-on ("init-environment" "impl-dependent"))
+ ))
diff --git a/dev-lisp/cl-environment/metadata.xml b/dev-lisp/cl-environment/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-environment/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>