summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild')
-rw-r--r--dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild b/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild
new file mode 100644
index 000000000000..20981a6f91b8
--- /dev/null
+++ b/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-environment/cl-environment-1.0.20021105.ebuild,v 1.1 2004/05/14 19:12:51 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:3}
+CVS_PV=${PV:4:4}.${PV:8:2}.${PV:10}
+
+DESCRIPTION="Provides an CLOS (CL Object System) encapsulation of the current CL implementation environment"
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-environment"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-environment/cl-environment_${MY_PV}+cvs.${CVS_PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=environment
+
+S=${WORKDIR}/cl-environment-${MY_PV}+cvs.${CVS_PV}
+
+src_install() {
+ common-lisp-install *.lisp ${FILESDIR}/environment.asd
+ insinto ${CLSOURCEROOT}/${CLPACKAGE}/impl-dependent; doins impl-dependent/*.lisp
+ common-lisp-system-symlink
+ dodoc COPYING INSTALLATION README
+}