summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-27 08:47:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-27 08:47:30 +0000
commitef9c9823e90029b9b1a06dfd09f4e4b1879054f0 (patch)
treeed72b75b0018f99b452aa68297d84452a304779f /sys-apps/slocate
parentprune ebuilds (diff)
downloadhistorical-ef9c9823e90029b9b1a06dfd09f4e4b1879054f0.tar.gz
historical-ef9c9823e90029b9b1a06dfd09f4e4b1879054f0.tar.bz2
historical-ef9c9823e90029b9b1a06dfd09f4e4b1879054f0.zip
Use ROOT in pkg_postinst; error messages; error check sed
Diffstat (limited to 'sys-apps/slocate')
-rw-r--r--sys-apps/slocate/ChangeLog5
-rw-r--r--sys-apps/slocate/Manifest4
-rw-r--r--sys-apps/slocate/slocate-2.7-r5.ebuild28
3 files changed, 20 insertions, 17 deletions
diff --git a/sys-apps/slocate/ChangeLog b/sys-apps/slocate/ChangeLog
index 6b2de455ba3e..49507d53e1b8 100644
--- a/sys-apps/slocate/ChangeLog
+++ b/sys-apps/slocate/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/slocate
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.46 2004/07/27 08:36:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.47 2004/07/27 08:47:30 mr_bones_ Exp $
+
+ 27 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> slocate-2.7-r5.ebuild:
+ Use ROOT in pkg_postinst; error messages; error check sed
27 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> -slocate-2.7-r2.ebuild,
-slocate-2.7-r3.ebuild, -slocate-2.7-r4.ebuild:
diff --git a/sys-apps/slocate/Manifest b/sys-apps/slocate/Manifest
index dec7ea475d58..ec8e74444b54 100644
--- a/sys-apps/slocate/Manifest
+++ b/sys-apps/slocate/Manifest
@@ -1,5 +1,5 @@
-MD5 8eadc3da92bd2b046f2dfe7a9d78fea5 ChangeLog 5950
+MD5 6ea721bc7c198316df4e1cdc0fe4fe04 ChangeLog 6089
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 c55940ff299338519db199aa12061422 slocate-2.7-r5.ebuild 2487
+MD5 3a16b74d22e66bf6543585bef4e091f9 slocate-2.7-r5.ebuild 2619
MD5 1d6262a2616b8521ac7b81c950b1346a files/updatedb.conf 622
MD5 4bdd089557d4d782d79f12dff709c202 files/digest-slocate-2.7-r5 137
diff --git a/sys-apps/slocate/slocate-2.7-r5.ebuild b/sys-apps/slocate/slocate-2.7-r5.ebuild
index bd438365c358..51e78d8636f4 100644
--- a/sys-apps/slocate/slocate-2.7-r5.ebuild
+++ b/sys-apps/slocate/slocate-2.7-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.7-r5.ebuild,v 1.15 2004/06/24 22:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.7-r5.ebuild,v 1.16 2004/07/27 08:47:30 mr_bones_ Exp $
inherit flag-o-matic eutils
@@ -34,7 +34,7 @@ src_install() {
dodir /usr/share/man/man1
sed -i -e "/groupadd/s/^/#/;/chown.*slocate/s/^/#/" Makefile || die
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
# make install for this package is blocked by sandbox
dosym slocate /usr/bin/locate
@@ -44,41 +44,42 @@ src_install() {
# fix bug 37354: nice updatedb
sed -i -e 's,^\([[:space:]]*\)\(/usr/bin/updatedb\),\1nice \2,' \
- ${D}/etc/cron.daily/slocate
+ "${D}/etc/cron.daily/slocate" \
+ || die "sed ${D}/etc/cron.daily/slocate failed"
- dodoc INSTALL AUTHORS NEWS README ChangeLog
+ dodoc AUTHORS README ChangeLog
# man page fixing
- rm -f ${D}/usr/share/man/man1/locate.1.gz
+ rm -f "${D}/usr/share/man/man1/locate.1.gz"
dosym slocate.1.gz /usr/share/man/man1/locate.1.gz
insinto /etc
- doins ${FILESDIR}/updatedb.conf
+ doins "${FILESDIR}/updatedb.conf"
fperms 0644 /etc/updatedb.conf
}
pkg_postinst() {
- touch /var/lib/slocate/slocate.db
+ touch "${ROOT}/var/lib/slocate/slocate.db"
# /var/lib/slocate is owned by group slocate and so is the executable
if ! groupmod slocate; then
groupadd slocate 2> /dev/null || die "Failed to create slocate group"
fi
- chown root:slocate /usr/bin/slocate
+ chown root:slocate "${ROOT}/usr/bin/slocate"
# If nobody else minds I'd like to see 2711 become the system wide default.
# -solar
if has sfperms ${FEATURES}; then
- chmod 2711 /usr/bin/slocate
+ chmod 2711 "${ROOT}/usr/bin/slocate"
else
- chmod 2755 /usr/bin/slocate
+ chmod 2755 "${ROOT}/usr/bin/slocate"
fi
- chown -R root:slocate /var/lib/slocate
- chmod 0750 /var/lib/slocate
+ chown -R root:slocate "${ROOT}/var/lib/slocate"
+ chmod 0750 "${ROOT}/var/lib/slocate"
- if [[ -f /etc/cron.daily/slocate.cron ]]; then
+ if [[ -f "${ROOT}/etc/cron.daily/slocate.cron" ]]; then
ewarn
ewarn "If you merged slocate-2.7.ebuild, please remove"
ewarn "/etc/cron.daily/slocate.cron since .cron has been removed"
@@ -86,7 +87,6 @@ pkg_postinst() {
ewarn
echo
fi
-
einfo
einfo "Note that the /etc/updatedb.conf file is generic"
einfo "Please customize it to your system requirements"