summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/slocate/slocate-2.7-r5.ebuild')
-rw-r--r--sys-apps/slocate/slocate-2.7-r5.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-apps/slocate/slocate-2.7-r5.ebuild b/sys-apps/slocate/slocate-2.7-r5.ebuild
index bd438365c358..51e78d8636f4 100644
--- a/sys-apps/slocate/slocate-2.7-r5.ebuild
+++ b/sys-apps/slocate/slocate-2.7-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.7-r5.ebuild,v 1.15 2004/06/24 22:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.7-r5.ebuild,v 1.16 2004/07/27 08:47:30 mr_bones_ Exp $
inherit flag-o-matic eutils
@@ -34,7 +34,7 @@ src_install() {
dodir /usr/share/man/man1
sed -i -e "/groupadd/s/^/#/;/chown.*slocate/s/^/#/" Makefile || die
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
# make install for this package is blocked by sandbox
dosym slocate /usr/bin/locate
@@ -44,41 +44,42 @@ src_install() {
# fix bug 37354: nice updatedb
sed -i -e 's,^\([[:space:]]*\)\(/usr/bin/updatedb\),\1nice \2,' \
- ${D}/etc/cron.daily/slocate
+ "${D}/etc/cron.daily/slocate" \
+ || die "sed ${D}/etc/cron.daily/slocate failed"
- dodoc INSTALL AUTHORS NEWS README ChangeLog
+ dodoc AUTHORS README ChangeLog
# man page fixing
- rm -f ${D}/usr/share/man/man1/locate.1.gz
+ rm -f "${D}/usr/share/man/man1/locate.1.gz"
dosym slocate.1.gz /usr/share/man/man1/locate.1.gz
insinto /etc
- doins ${FILESDIR}/updatedb.conf
+ doins "${FILESDIR}/updatedb.conf"
fperms 0644 /etc/updatedb.conf
}
pkg_postinst() {
- touch /var/lib/slocate/slocate.db
+ touch "${ROOT}/var/lib/slocate/slocate.db"
# /var/lib/slocate is owned by group slocate and so is the executable
if ! groupmod slocate; then
groupadd slocate 2> /dev/null || die "Failed to create slocate group"
fi
- chown root:slocate /usr/bin/slocate
+ chown root:slocate "${ROOT}/usr/bin/slocate"
# If nobody else minds I'd like to see 2711 become the system wide default.
# -solar
if has sfperms ${FEATURES}; then
- chmod 2711 /usr/bin/slocate
+ chmod 2711 "${ROOT}/usr/bin/slocate"
else
- chmod 2755 /usr/bin/slocate
+ chmod 2755 "${ROOT}/usr/bin/slocate"
fi
- chown -R root:slocate /var/lib/slocate
- chmod 0750 /var/lib/slocate
+ chown -R root:slocate "${ROOT}/var/lib/slocate"
+ chmod 0750 "${ROOT}/var/lib/slocate"
- if [[ -f /etc/cron.daily/slocate.cron ]]; then
+ if [[ -f "${ROOT}/etc/cron.daily/slocate.cron" ]]; then
ewarn
ewarn "If you merged slocate-2.7.ebuild, please remove"
ewarn "/etc/cron.daily/slocate.cron since .cron has been removed"
@@ -86,7 +87,6 @@ pkg_postinst() {
ewarn
echo
fi
-
einfo
einfo "Note that the /etc/updatedb.conf file is generic"
einfo "Please customize it to your system requirements"