summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-04 08:01:14 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-04 08:01:14 +0000
commit2b3c01040903c5b5fd4f70f660a95f68c6d7fb0f (patch)
tree63da2e96c0b32ececdb8bf1ea012030742635921 /net-libs
parentinitial import (diff)
downloadhistorical-2b3c01040903c5b5fd4f70f660a95f68c6d7fb0f.tar.gz
historical-2b3c01040903c5b5fd4f70f660a95f68c6d7fb0f.tar.bz2
historical-2b3c01040903c5b5fd4f70f660a95f68c6d7fb0f.zip
initial import
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libyahoo2/Manifest5
-rw-r--r--net-libs/libyahoo2/files/digest-libyahoo2-0.7.21
-rw-r--r--net-libs/libyahoo2/files/sample_client.c-gentoo.patch11
-rw-r--r--net-libs/libyahoo2/libyahoo2-0.7.2.ebuild35
4 files changed, 50 insertions, 2 deletions
diff --git a/net-libs/libyahoo2/Manifest b/net-libs/libyahoo2/Manifest
index 1d3eb49032e1..b3112a0ce654 100644
--- a/net-libs/libyahoo2/Manifest
+++ b/net-libs/libyahoo2/Manifest
@@ -1,3 +1,4 @@
-MD5 5a9697c594c7a641c157a249b5c08c2e libyahoo2-0.7.2.ebuild 2178
-MD5 652f011c07ca925858993d5f54bc1f06 libyahoo2-0.7.2.ebuild~ 6006
+MD5 30597e2ae2d20acd4775afa1f9b955b2 libyahoo2-0.7.2.ebuild 875
+MD5 fade395d9db0cefc601510663b834b6f ChangeLog 384
MD5 3fb42370f3e2bf66f10976db27b319b7 files/digest-libyahoo2-0.7.2 67
+MD5 de86c0af428d9f917da128e8b15b4e03 files/sample_client.c-gentoo.patch 462
diff --git a/net-libs/libyahoo2/files/digest-libyahoo2-0.7.2 b/net-libs/libyahoo2/files/digest-libyahoo2-0.7.2
new file mode 100644
index 000000000000..85fad6de3cf1
--- /dev/null
+++ b/net-libs/libyahoo2/files/digest-libyahoo2-0.7.2
@@ -0,0 +1 @@
+MD5 e666b4d480d9d974714a11f254d0f1e6 libyahoo2-0.7.2.tar.gz 262029
diff --git a/net-libs/libyahoo2/files/sample_client.c-gentoo.patch b/net-libs/libyahoo2/files/sample_client.c-gentoo.patch
new file mode 100644
index 000000000000..4bfe6a3447cf
--- /dev/null
+++ b/net-libs/libyahoo2/files/sample_client.c-gentoo.patch
@@ -0,0 +1,11 @@
+--- libyahoo2-0.7.2/src/sample_client.c~ 2003-09-28 12:40:03.000000000 -0500
++++ libyahoo2-0.7.2/src/sample_client.c 2003-10-04 01:09:54.592275960 -0500
+@@ -654,7 +654,7 @@
+ }
+
+ void ext_yahoo_got_webcam_image(int id, const char *who,
+- unsigned char *image, unsigned int image_size, unsigned int real_size,
++ const unsigned char *image, unsigned int image_size, unsigned int real_size,
+ unsigned int timestamp)
+ {
+ static unsigned char *cur_image = NULL;
diff --git a/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild b/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild
new file mode 100644
index 000000000000..0fbe7701b2a3
--- /dev/null
+++ b/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild,v 1.1 2003/10/04 08:01:12 mkennedy Exp $
+
+DESCRIPTION="libyahoo2 is a C library interface to the new Yahoo! Messenger protocol. It supports almost all current features of the protocol."
+HOMEPAGE="http://libyahoo2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/sample_client.c-gentoo.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dobin src/yahoo
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dodoc doc/*.txt
+ docinto sample
+ dodoc src/sample_client.c src/sample_makefile
+
+}