summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libyahoo2/libyahoo2-0.7.2.ebuild')
-rw-r--r--net-libs/libyahoo2/libyahoo2-0.7.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild b/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild
new file mode 100644
index 000000000000..0fbe7701b2a3
--- /dev/null
+++ b/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libyahoo2/libyahoo2-0.7.2.ebuild,v 1.1 2003/10/04 08:01:12 mkennedy Exp $
+
+DESCRIPTION="libyahoo2 is a C library interface to the new Yahoo! Messenger protocol. It supports almost all current features of the protocol."
+HOMEPAGE="http://libyahoo2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/sample_client.c-gentoo.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dobin src/yahoo
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dodoc doc/*.txt
+ docinto sample
+ dodoc src/sample_client.c src/sample_makefile
+
+}