summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-08 19:27:19 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-08 19:27:19 +0000
commitb00d1e44a90a209b34a91e6fdc8d809802f3d89c (patch)
treed9150c6405ed206798a24f3d9dc0288edf9f5fc9 /net-libs/nss_ldap
parent*** empty log message *** (diff)
downloadhistorical-b00d1e44a90a209b34a91e6fdc8d809802f3d89c.tar.gz
historical-b00d1e44a90a209b34a91e6fdc8d809802f3d89c.tar.bz2
historical-b00d1e44a90a209b34a91e6fdc8d809802f3d89c.zip
*** empty log message ***
Diffstat (limited to 'net-libs/nss_ldap')
-rw-r--r--net-libs/nss_ldap/files/digest1
-rw-r--r--net-libs/nss_ldap/nss_ldap-110-r1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/nss_ldap/files/digest b/net-libs/nss_ldap/files/digest
new file mode 100644
index 000000000000..778a54465343
--- /dev/null
+++ b/net-libs/nss_ldap/files/digest
@@ -0,0 +1 @@
+MD5 fb7be1157e3f0daca17750cc1185cb76 nss_ldap.tgz
diff --git a/net-libs/nss_ldap/nss_ldap-110-r1.ebuild b/net-libs/nss_ldap/nss_ldap-110-r1.ebuild
new file mode 100644
index 000000000000..6ef45c96b7c8
--- /dev/null
+++ b/net-libs/nss_ldap/nss_ldap-110-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nss_ldap/nss_ldap-110-r1.ebuild,v 1.1 2000/08/08 19:27:19 achim Exp $
+
+P=nss_ldap-110
+A=nss_ldap.tgz
+S=${WORKDIR}/${P}
+CATEGORY="net-libs"
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/nss_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/"${A}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s/^NSFLAGS/#NSFLAGS/" \
+ -e "s/-lsasl//" \
+ -e "s/-O/${CFLAGS}/" Makefile.linux.openldap2 > Makefile
+}
+
+src_compile() {
+ cd ${S}
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dolib.so libnss_ldap-2.1.3.so
+ into /usr
+ doman *.1
+ insinto /etc
+ doins nsswitch.ldap
+ insinto /usr/bin
+ insopts -m755
+ doins ldaptest.pl
+ dodoc ldap.conf ANNOUNCE BUGS ChangeLog CONTRIBUTORS COPYING.LIB
+ dodoc CVSVersionInfo.txt IRS README rfc*.txt nsswitch.test
+}
+
+
+
+
+
+