summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-08 19:27:19 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-08 19:27:19 +0000
commitb00d1e44a90a209b34a91e6fdc8d809802f3d89c (patch)
treed9150c6405ed206798a24f3d9dc0288edf9f5fc9 /net-libs
parent*** empty log message *** (diff)
downloadhistorical-b00d1e44a90a209b34a91e6fdc8d809802f3d89c.tar.gz
historical-b00d1e44a90a209b34a91e6fdc8d809802f3d89c.tar.bz2
historical-b00d1e44a90a209b34a91e6fdc8d809802f3d89c.zip
*** empty log message ***
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/files/digest1
-rw-r--r--net-libs/libpcap/libpcap-0.5-r1.ebuild35
-rw-r--r--net-libs/nss_ldap/files/digest1
-rw-r--r--net-libs/nss_ldap/nss_ldap-110-r1.ebuild46
-rw-r--r--net-libs/pam_ldap/files/digest1
-rw-r--r--net-libs/pam_ldap/pam_ldap-61-r1.ebuild39
6 files changed, 123 insertions, 0 deletions
diff --git a/net-libs/libpcap/files/digest b/net-libs/libpcap/files/digest
new file mode 100644
index 000000000000..123faa666b47
--- /dev/null
+++ b/net-libs/libpcap/files/digest
@@ -0,0 +1 @@
+MD5 818e64467ba84585b1d0fe280693f570 libpcap-0.5.tar.gz
diff --git a/net-libs/libpcap/libpcap-0.5-r1.ebuild b/net-libs/libpcap/libpcap-0.5-r1.ebuild
new file mode 100644
index 000000000000..84f26b5d78b1
--- /dev/null
+++ b/net-libs/libpcap/libpcap-0.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-0.5-r1.ebuild,v 1.1 2000/08/08 19:27:19 achim Exp $
+
+P=libpcap-0.5
+A=${P}.tar.gz
+S=${WORKDIR}/libpcap_0_5rel2
+CATEGORY="net-libs"
+DESCRIPTION="pcap-Library"
+SRC_URI="http://www.tcpdump.org/release/${A}
+ http://www.jp.tcpdump.org/release/${A}"
+
+HOMEPAGE="http://www.tcpdump.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --enable-ipv6
+ make
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib
+ dodir /usr/include/net
+ dodir /usr/man/man3
+ make prefix=${D}/usr install
+ make prefix=${D}/usr install-incl
+ make prefix=${D}/usr install-man
+ prepman
+ dodoc CREDITS CHANGES FILES README VERSION
+}
+
+
+
diff --git a/net-libs/nss_ldap/files/digest b/net-libs/nss_ldap/files/digest
new file mode 100644
index 000000000000..778a54465343
--- /dev/null
+++ b/net-libs/nss_ldap/files/digest
@@ -0,0 +1 @@
+MD5 fb7be1157e3f0daca17750cc1185cb76 nss_ldap.tgz
diff --git a/net-libs/nss_ldap/nss_ldap-110-r1.ebuild b/net-libs/nss_ldap/nss_ldap-110-r1.ebuild
new file mode 100644
index 000000000000..6ef45c96b7c8
--- /dev/null
+++ b/net-libs/nss_ldap/nss_ldap-110-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nss_ldap/nss_ldap-110-r1.ebuild,v 1.1 2000/08/08 19:27:19 achim Exp $
+
+P=nss_ldap-110
+A=nss_ldap.tgz
+S=${WORKDIR}/${P}
+CATEGORY="net-libs"
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/nss_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/"${A}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s/^NSFLAGS/#NSFLAGS/" \
+ -e "s/-lsasl//" \
+ -e "s/-O/${CFLAGS}/" Makefile.linux.openldap2 > Makefile
+}
+
+src_compile() {
+ cd ${S}
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dolib.so libnss_ldap-2.1.3.so
+ into /usr
+ doman *.1
+ insinto /etc
+ doins nsswitch.ldap
+ insinto /usr/bin
+ insopts -m755
+ doins ldaptest.pl
+ dodoc ldap.conf ANNOUNCE BUGS ChangeLog CONTRIBUTORS COPYING.LIB
+ dodoc CVSVersionInfo.txt IRS README rfc*.txt nsswitch.test
+}
+
+
+
+
+
+
diff --git a/net-libs/pam_ldap/files/digest b/net-libs/pam_ldap/files/digest
new file mode 100644
index 000000000000..833f0c355a8c
--- /dev/null
+++ b/net-libs/pam_ldap/files/digest
@@ -0,0 +1 @@
+MD5 b8567a6cc5086558bdfefec3fd4babc2 pam_ldap.tgz
diff --git a/net-libs/pam_ldap/pam_ldap-61-r1.ebuild b/net-libs/pam_ldap/pam_ldap-61-r1.ebuild
new file mode 100644
index 000000000000..c36338836938
--- /dev/null
+++ b/net-libs/pam_ldap/pam_ldap-61-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pam_ldap/pam_ldap-61-r1.ebuild,v 1.1 2000/08/08 19:27:19 achim Exp $
+
+P=pam_ldap-61
+A=pam_ldap.tgz
+S=${WORKDIR}/${P}
+CATEGORY="net-libs"
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/pam_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/"${A}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ touch NEWS
+ touch AUTHORS
+ ./configure --host=${CHOST} --prefix=/usr --with-ldap-lib=openldap
+ make
+}
+
+src_install() {
+ cd ${S}
+ exeinto /usr/lib/security
+ doexe pam_ldap.so
+ dodoc pam.conf ldap.conf
+ dodoc ChangeLog COPYING.* CVSVersionInfo.txt README
+ docinto pam.d
+ dodoc pam.d/*
+}
+
+
+
+
+