summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-03-29 19:11:20 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-03-29 19:11:20 +0000
commit316c0410c7f2c159558f6d348c19dafbc0fc09d4 (patch)
tree3065aa2449b740196baba4dea01fdf94bd8938b0 /net-im/gabber/gabber-1.9.3.ebuild
parentFixes #46135 (diff)
downloadhistorical-316c0410c7f2c159558f6d348c19dafbc0fc09d4.tar.gz
historical-316c0410c7f2c159558f6d348c19dafbc0fc09d4.tar.bz2
historical-316c0410c7f2c159558f6d348c19dafbc0fc09d4.zip
Small cosmetic change to use gnome2 eclass.
Diffstat (limited to 'net-im/gabber/gabber-1.9.3.ebuild')
-rw-r--r--net-im/gabber/gabber-1.9.3.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/net-im/gabber/gabber-1.9.3.ebuild b/net-im/gabber/gabber-1.9.3.ebuild
index 377b614fba94..58298a3f0cf5 100644
--- a/net-im/gabber/gabber-1.9.3.ebuild
+++ b/net-im/gabber/gabber-1.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/gabber-1.9.3.ebuild,v 1.1 2004/03/28 20:05:19 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/gabber-1.9.3.ebuild,v 1.2 2004/03/29 19:11:20 humpback Exp $
inherit gnome2
@@ -11,33 +11,33 @@ HOMEPAGE="http://gabber.jabberstudio.org/"
SRC_URI="http://www.jabberstudio.org/files/gabber/${MY_PN}-${PV}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="1"
KEYWORDS="~x86"
-IUSE="debug spell ssl xss X"
+IUSE="spell ssl"
DEPEND="sys-devel/gettext
>=dev-cpp/gtkmm-2.0
>=dev-cpp/gconfmm-2.0
>=dev-cpp/libglademm-2.0
>=net-im/jabberoo-1.9.0
+ dev-util/pkgconfig
ssl? ( dev-libs/openssl )
spell? ( app-text/gtkspell )"
+
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_PN}-${PV}
-src_compile() {
- local myconf
-
- use ssl && myconf=${myconf} || myconf="${myconf} --disable-ssl"
- use spell && myconf=${myconf} || myconf="${myconf} --disable-gtkspell"
- use xss && myconf=${myconf} || myconf="${myconf} --disable-xss"
- use X && myconf="${myconf} --with-x"
-
- myconf="${myconf} --sysconfdir=${D}/etc"
+# This is beta code, shoul turn debug on so that messages to developers
+# come with extra info
+MYCONF="--enable-debug"
+use ssl && MYCONF=${MYCONF} || MYCONF="${MYCONF} --disable-ssl"
+use spell && MYCONF=${MYCONF} || MYCONF="${MYCONF} --disable-gtkspell"
- econf ${myconf} || die "configure failed"
+# The configure works bad with this see bug 45758
+#G2CONF="${G2CONF} $(use_enable ssl)"
+#G2CONF="${G2CONF} $(use_enable spell gtkspell)"
+G2CONF="${G2CONF} ${MYCONF}"
- emake || die "make failed"
-}
+DOCS="AUTHORS ChangeLog COPYING HACKING HACKING.ideas NEWS README TODO"