summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-03-29 19:11:20 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-03-29 19:11:20 +0000
commit316c0410c7f2c159558f6d348c19dafbc0fc09d4 (patch)
tree3065aa2449b740196baba4dea01fdf94bd8938b0 /net-im
parentFixes #46135 (diff)
downloadhistorical-316c0410c7f2c159558f6d348c19dafbc0fc09d4.tar.gz
historical-316c0410c7f2c159558f6d348c19dafbc0fc09d4.tar.bz2
historical-316c0410c7f2c159558f6d348c19dafbc0fc09d4.zip
Small cosmetic change to use gnome2 eclass.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gabber/ChangeLog6
-rw-r--r--net-im/gabber/Manifest6
-rw-r--r--net-im/gabber/gabber-1.9.3.ebuild30
-rw-r--r--net-im/gabber/metadata.xml4
4 files changed, 26 insertions, 20 deletions
diff --git a/net-im/gabber/ChangeLog b/net-im/gabber/ChangeLog
index a65de45e8640..f8dd4ed94474 100644
--- a/net-im/gabber/ChangeLog
+++ b/net-im/gabber/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/gabber
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/ChangeLog,v 1.20 2004/03/28 20:05:19 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/ChangeLog,v 1.21 2004/03/29 19:11:20 humpback Exp $
+
+ 29 Mar 2004; Gustavo Felisberto <humpback@gentoo.org>; gabber-1.9.3.ebuild,
+ metadata.xml:
+ Some cosmetic changes see bug 45758
*gabber-1.9.3 (28 Mar 2004)
diff --git a/net-im/gabber/Manifest b/net-im/gabber/Manifest
index 762cfb3725dc..a751a646b400 100644
--- a/net-im/gabber/Manifest
+++ b/net-im/gabber/Manifest
@@ -1,9 +1,9 @@
MD5 76087b8d4373f1744a272b85e6f7f965 gabber-0.8.7-r3.ebuild 1515
-MD5 f0436d02af8db6d7c0e8a88599b0b6f2 metadata.xml 277
+MD5 e70c297e90595ae6039448e27b7cada3 metadata.xml 434
MD5 3a964b093e135f57354602e61120d38f gabber-0.8.7.12.ebuild 1456
-MD5 25112138d1bec8108abeeed84db7291a ChangeLog 3303
+MD5 f6d878c24f60424142352da8188e1b53 ChangeLog 3436
MD5 d80060972f60c3a7faf6f64957f4793c gabber-0.8.8.ebuild 1533
-MD5 6d871d6df6c403417968d5541fde7f70 gabber-1.9.3.ebuild 1136
+MD5 affa2774e40db373cbbc749c8214c9dc gabber-1.9.3.ebuild 1251
MD5 7b501a37a16efd3cbc0903c924105f30 files/digest-gabber-1.9.3 64
MD5 3c26fdd6bd493036699f43145aad0613 files/TCPtransmitter.cc-gcc3-gentoo.patch 584
MD5 13fd2ef7cc09c0d0e358f639c31f687e files/digest-gabber-0.8.7-r3 65
diff --git a/net-im/gabber/gabber-1.9.3.ebuild b/net-im/gabber/gabber-1.9.3.ebuild
index 377b614fba94..58298a3f0cf5 100644
--- a/net-im/gabber/gabber-1.9.3.ebuild
+++ b/net-im/gabber/gabber-1.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/gabber-1.9.3.ebuild,v 1.1 2004/03/28 20:05:19 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/gabber-1.9.3.ebuild,v 1.2 2004/03/29 19:11:20 humpback Exp $
inherit gnome2
@@ -11,33 +11,33 @@ HOMEPAGE="http://gabber.jabberstudio.org/"
SRC_URI="http://www.jabberstudio.org/files/gabber/${MY_PN}-${PV}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="1"
KEYWORDS="~x86"
-IUSE="debug spell ssl xss X"
+IUSE="spell ssl"
DEPEND="sys-devel/gettext
>=dev-cpp/gtkmm-2.0
>=dev-cpp/gconfmm-2.0
>=dev-cpp/libglademm-2.0
>=net-im/jabberoo-1.9.0
+ dev-util/pkgconfig
ssl? ( dev-libs/openssl )
spell? ( app-text/gtkspell )"
+
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_PN}-${PV}
-src_compile() {
- local myconf
-
- use ssl && myconf=${myconf} || myconf="${myconf} --disable-ssl"
- use spell && myconf=${myconf} || myconf="${myconf} --disable-gtkspell"
- use xss && myconf=${myconf} || myconf="${myconf} --disable-xss"
- use X && myconf="${myconf} --with-x"
-
- myconf="${myconf} --sysconfdir=${D}/etc"
+# This is beta code, shoul turn debug on so that messages to developers
+# come with extra info
+MYCONF="--enable-debug"
+use ssl && MYCONF=${MYCONF} || MYCONF="${MYCONF} --disable-ssl"
+use spell && MYCONF=${MYCONF} || MYCONF="${MYCONF} --disable-gtkspell"
- econf ${myconf} || die "configure failed"
+# The configure works bad with this see bug 45758
+#G2CONF="${G2CONF} $(use_enable ssl)"
+#G2CONF="${G2CONF} $(use_enable spell gtkspell)"
+G2CONF="${G2CONF} ${MYCONF}"
- emake || die "make failed"
-}
+DOCS="AUTHORS ChangeLog COPYING HACKING HACKING.ideas NEWS README TODO"
diff --git a/net-im/gabber/metadata.xml b/net-im/gabber/metadata.xml
index 6afde6408f93..514f79e3841a 100644
--- a/net-im/gabber/metadata.xml
+++ b/net-im/gabber/metadata.xml
@@ -4,6 +4,8 @@
<herd>net-im</herd>
<maintainer>
<email>net-im@gentoo.org</email>
+ <description>The code on the 1.9.* versions is very buggy, please report problems to humpback@gentoo.org</description>
</maintainer>
- <longdescription>Gnome Jabber client</longdescription>
+
+<longdescription>The next generation of Gabber: The Gnome Jabber Client.</longdescription>
</pkgmetadata>