summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-28 16:40:45 +0000
committerMax Kalika <max@gentoo.org>2003-10-28 16:40:45 +0000
commitb6e3e83e63e88d6281deaffb4f5a4dec095ea4f3 (patch)
treed952a7cce4971e41abb2a813ef468b8e87481685 /media-plugins/mythweather
parentExtend CPU detection. (diff)
downloadhistorical-b6e3e83e63e88d6281deaffb4f5a4dec095ea4f3.tar.gz
historical-b6e3e83e63e88d6281deaffb4f5a4dec095ea4f3.tar.bz2
historical-b6e3e83e63e88d6281deaffb4f5a4dec095ea4f3.zip
Extend CPU detection.
Diffstat (limited to 'media-plugins/mythweather')
-rw-r--r--media-plugins/mythweather/ChangeLog5
-rw-r--r--media-plugins/mythweather/Manifest4
-rw-r--r--media-plugins/mythweather/mythweather-0.12.ebuild4
3 files changed, 8 insertions, 5 deletions
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
index 9ff01125c0c0..56906017c6ed 100644
--- a/media-plugins/mythweather/ChangeLog
+++ b/media-plugins/mythweather/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-plugins/mythweather
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.6 2003/10/20 03:34:29 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.7 2003/10/28 16:40:44 max Exp $
+
+ 28 Oct 2003; Max Kalika <max@gentoo.org> mythweather-0.12.ebuild:
+ Extend CPU detection.
*mythweather-0.12 (19 Oct 2003)
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
index 03d03fe5b776..94c88ba6d8d7 100644
--- a/media-plugins/mythweather/Manifest
+++ b/media-plugins/mythweather/Manifest
@@ -1,7 +1,7 @@
-MD5 5230ef18d7189354c4925becd1247dc0 mythweather-0.12.ebuild 962
+MD5 860c410d8ecf89fca2f87188220346b7 mythweather-0.12.ebuild 979
MD5 103f2dc2a77568b205f86d9f8a21e4a8 mythweather-0.11.ebuild 972
MD5 d7ca666cb6cccf06ea43cd7a48ae62ee mythweather-0.10.ebuild 1005
-MD5 8d11231e8a232a429760dc93f1567cc5 ChangeLog 1586
+MD5 1ce9e7a9a91881662ce4e55b63d1e126 ChangeLog 1679
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 09666f4a410bc5eda6781edd029505f7 files/digest-mythweather-0.10 69
MD5 6a31e4f0a87c61e3e7f0eb55dca2f03b files/digest-mythweather-0.11 69
diff --git a/media-plugins/mythweather/mythweather-0.12.ebuild b/media-plugins/mythweather/mythweather-0.12.ebuild
index e6cb52656f81..8aceeca9c9e8 100644
--- a/media-plugins/mythweather/mythweather-0.12.ebuild
+++ b/media-plugins/mythweather/mythweather-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.12.ebuild,v 1.1 2003/10/20 03:34:29 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.12.ebuild,v 1.2 2003/10/28 16:40:44 max Exp $
inherit flag-o-matic
@@ -24,7 +24,7 @@ src_unpack() {
}
src_compile() {
- local cpu="`get-flag march`"
+ local cpu="`get-flag march || get-flag mcpu`"
if [ ! -z "${cpu}" ] ; then
sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
fi