summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2003-10-06 05:23:22 +0000
committerRob Cakebread <pythonhead@gentoo.org>2003-10-06 05:23:22 +0000
commit62f04f530ba5aa6db56d97884fffb64c976f309f (patch)
treee748ea0526758e7202476649ee3ba31df7a8461a /dev-python/mod_python
parentVersion bump (diff)
downloadhistorical-62f04f530ba5aa6db56d97884fffb64c976f309f.tar.gz
historical-62f04f530ba5aa6db56d97884fffb64c976f309f.tar.bz2
historical-62f04f530ba5aa6db56d97884fffb64c976f309f.zip
Version bump
Diffstat (limited to 'dev-python/mod_python')
-rw-r--r--dev-python/mod_python/Manifest4
-rw-r--r--dev-python/mod_python/files/digest-mod_python-3.0.31
-rw-r--r--dev-python/mod_python/files/mod_python-3.0.3-dest1.diff11
-rw-r--r--dev-python/mod_python/files/mod_python-3.0.3-dest2.diff11
-rw-r--r--dev-python/mod_python/mod_python-3.0.3.ebuild47
5 files changed, 72 insertions, 2 deletions
diff --git a/dev-python/mod_python/Manifest b/dev-python/mod_python/Manifest
index 27ac180a69ff..4a48010a4460 100644
--- a/dev-python/mod_python/Manifest
+++ b/dev-python/mod_python/Manifest
@@ -1,9 +1,9 @@
-MD5 ac44894ed9f80346bad32e4619b0d7e8 ChangeLog 1112
+MD5 50cc1f08f376ce19da1037570557c21f ChangeLog 1114
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 e1b86e5574bcdb91f2574b467320fd89 mod_python-2.7.8.ebuild 2482
MD5 7ece881d024e39baf7b7a1886bcaa4c5 mod_python-3.0.0_beta4.ebuild 1175
MD5 d30d99c41e7e02b6bad3e7d773558f9d mod_python-3.0.1.ebuild 1098
-MD5 f6996174cf5ae630bc56510734ebe41b mod_python-3.0.3.ebuild 1394
+MD5 b36c95b1ad624c1fec95ca96b4360201 mod_python-3.0.3.ebuild 1506
MD5 05bbbfafd26dcf70f83fcc2b015751dc files/16_mod_python.conf 1106
MD5 0cbbebc73f7833ec15b734bfe8397496 files/digest-mod_python-2.7.8 131
MD5 9fad9dcefc830c5d9f6bba7792e59f15 files/digest-mod_python-3.0.0_beta4 71
diff --git a/dev-python/mod_python/files/digest-mod_python-3.0.3 b/dev-python/mod_python/files/digest-mod_python-3.0.3
new file mode 100644
index 000000000000..6d6688b42e98
--- /dev/null
+++ b/dev-python/mod_python/files/digest-mod_python-3.0.3
@@ -0,0 +1 @@
+MD5 39f8db0bafac6ce241599d2299b5d853 mod_python-3.0.3.tgz 219378
diff --git a/dev-python/mod_python/files/mod_python-3.0.3-dest1.diff b/dev-python/mod_python/files/mod_python-3.0.3-dest1.diff
new file mode 100644
index 000000000000..dba4c03578e1
--- /dev/null
+++ b/dev-python/mod_python/files/mod_python-3.0.3-dest1.diff
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2002-12-30 18:59:34.000000000 +0000
++++ Makefile.in 2003-09-08 01:56:03.000000000 +0000
+@@ -93,7 +93,7 @@
+ @echo
+ @echo "Performing DSO installation."
+ @echo
+- $(INSTALL) src/mod_python.so $(LIBEXECDIR)
++ $(INSTALL) src/mod_python.so $(DESTDIR)$(LIBEXECDIR)
+ @$(MAKE) install_py_lib
+ @echo
+ @echo "Now don't forget to edit your main config and add"
diff --git a/dev-python/mod_python/files/mod_python-3.0.3-dest2.diff b/dev-python/mod_python/files/mod_python-3.0.3-dest2.diff
new file mode 100644
index 000000000000..384ed145f0f3
--- /dev/null
+++ b/dev-python/mod_python/files/mod_python-3.0.3-dest2.diff
@@ -0,0 +1,11 @@
+--- dist/Makefile.in.orig 2003-09-08 02:26:56.000000000 +0000
++++ dist/Makefile.in 2003-09-08 02:29:20.000000000 +0000
+@@ -79,7 +79,7 @@
+ cd dist; \
+ gunzip -c mod_python-$(MP_VERSION).tar.gz | tar xf -; \
+ cd mod_python-$(MP_VERSION); \
+- $(PYTHON_BIN) setup.py install --optimize 2 --force; \
++ $(PYTHON_BIN) setup.py install --prefix=${DESTDIR}/usr --optimize 2 --force; \
+ cd ..; rm -rf mod_python-$(MP_VERSION)
+
+ mod_python.so:
diff --git a/dev-python/mod_python/mod_python-3.0.3.ebuild b/dev-python/mod_python/mod_python-3.0.3.ebuild
new file mode 100644
index 000000000000..a1e9e337b0e0
--- /dev/null
+++ b/dev-python/mod_python/mod_python-3.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.0.3.ebuild,v 1.1 2003/10/06 05:23:14 pythonhead Exp $
+
+
+DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
+HOMEPAGE="http://www.modpython.org/"
+SRC_URI="http://www.apache.org/dist/httpd/modpython/${P}.tgz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/python >=net-www/apache-2.0"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/${P}-dest1.diff
+ epatch ${FILESDIR}/${P}-dest2.diff
+}
+
+src_compile() {
+ ./configure --with-apxs=/usr/sbin/apxs2 || die
+ make OPT="`apxs2 -q CFLAGS` -fPIC" || die
+}
+
+src_install() {
+ dodir /usr/lib/{apache2,apache2-extramodules}
+ make install DESTDIR=${D} || die
+ mv ${D}/usr/lib/apache2/${PN}.so ${D}/usr/lib/apache2-extramodules
+ rm -rf ${D}/usr/lib/apache2
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/16_mod_python.conf
+ dodoc ${FILESDIR}/16_mod_python.conf README NEWS CREDITS COPYRIGHT
+ dohtml doc-html/*
+}
+
+pkg_postinst() {
+ einfo "To have Apache run python programs, please do the following:"
+ einfo "Edit /etc/conf.d/apache2 (/etc/conf.d/apache if you're using"
+ einfo "apache 1.x) and add \"-D PYTHON\""
+ einfo "That will setup Apache to load python when it starts."
+ einfo
+ einfo "If you're new to mod_python there's a manual and tutorial"
+ einfo "installed in /usr/share/doc/${P}/html/index.html."
+}
+