summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mod_python/mod_python-3.0.3.ebuild')
-rw-r--r--dev-python/mod_python/mod_python-3.0.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/mod_python/mod_python-3.0.3.ebuild b/dev-python/mod_python/mod_python-3.0.3.ebuild
new file mode 100644
index 000000000000..a1e9e337b0e0
--- /dev/null
+++ b/dev-python/mod_python/mod_python-3.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.0.3.ebuild,v 1.1 2003/10/06 05:23:14 pythonhead Exp $
+
+
+DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
+HOMEPAGE="http://www.modpython.org/"
+SRC_URI="http://www.apache.org/dist/httpd/modpython/${P}.tgz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/python >=net-www/apache-2.0"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/${P}-dest1.diff
+ epatch ${FILESDIR}/${P}-dest2.diff
+}
+
+src_compile() {
+ ./configure --with-apxs=/usr/sbin/apxs2 || die
+ make OPT="`apxs2 -q CFLAGS` -fPIC" || die
+}
+
+src_install() {
+ dodir /usr/lib/{apache2,apache2-extramodules}
+ make install DESTDIR=${D} || die
+ mv ${D}/usr/lib/apache2/${PN}.so ${D}/usr/lib/apache2-extramodules
+ rm -rf ${D}/usr/lib/apache2
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/16_mod_python.conf
+ dodoc ${FILESDIR}/16_mod_python.conf README NEWS CREDITS COPYRIGHT
+ dohtml doc-html/*
+}
+
+pkg_postinst() {
+ einfo "To have Apache run python programs, please do the following:"
+ einfo "Edit /etc/conf.d/apache2 (/etc/conf.d/apache if you're using"
+ einfo "apache 1.x) and add \"-D PYTHON\""
+ einfo "That will setup Apache to load python when it starts."
+ einfo
+ einfo "If you're new to mod_python there's a manual and tutorial"
+ einfo "installed in /usr/share/doc/${P}/html/index.html."
+}
+