summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-03-28 20:24:55 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-03-28 20:24:55 +0000
commit3cd7dc07a797678319b924cd9a55fbcee6871be2 (patch)
tree39ad3fe10179299f66f7e85faf1a82a304c18a6f /app-pda/libsyncml
parentReadd ~ia64 keyword wrt bug 170491 (diff)
downloadhistorical-3cd7dc07a797678319b924cd9a55fbcee6871be2.tar.gz
historical-3cd7dc07a797678319b924cd9a55fbcee6871be2.tar.bz2
historical-3cd7dc07a797678319b924cd9a55fbcee6871be2.zip
Version bump.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/ChangeLog8
-rw-r--r--app-pda/libsyncml/files/digest-libsyncml-0.4.43
-rw-r--r--app-pda/libsyncml/libsyncml-0.4.3.ebuild8
-rw-r--r--app-pda/libsyncml/libsyncml-0.4.4.ebuild74
4 files changed, 88 insertions, 5 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index b60ade249c6c..d63b81ba0b99 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libsyncml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.4 2007/02/12 20:54:36 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.5 2007/03/28 20:13:43 peper Exp $
+
+*libsyncml-0.4.4 (28 Mar 2007)
+
+ 28 Mar 2007; Piotr Jaroszyński <peper@gentoo.org> libsyncml-0.4.3.ebuild,
+ +libsyncml-0.4.4.ebuild:
+ Version bump.
*libsyncml-0.4.3 (12 Feb 2007)
diff --git a/app-pda/libsyncml/files/digest-libsyncml-0.4.4 b/app-pda/libsyncml/files/digest-libsyncml-0.4.4
new file mode 100644
index 000000000000..ab0e1d9078c8
--- /dev/null
+++ b/app-pda/libsyncml/files/digest-libsyncml-0.4.4
@@ -0,0 +1,3 @@
+MD5 192f42dc0a17e43edf5f893f1ca7fa5b libsyncml-0.4.4.tar.bz2 369680
+RMD160 f3daf946e6d4486ed6825f6fce6bceea59b37ed0 libsyncml-0.4.4.tar.bz2 369680
+SHA256 4b76e52279baa3aa52349a20c8c6aad00bdaa9e75ff471d02e72261815c70b2d libsyncml-0.4.4.tar.bz2 369680
diff --git a/app-pda/libsyncml/libsyncml-0.4.3.ebuild b/app-pda/libsyncml/libsyncml-0.4.3.ebuild
index ad841dc6171a..9c0907daf732 100644
--- a/app-pda/libsyncml/libsyncml-0.4.3.ebuild
+++ b/app-pda/libsyncml/libsyncml-0.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.3.ebuild,v 1.1 2007/02/12 20:54:36 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.3.ebuild,v 1.2 2007/03/28 20:13:43 peper Exp $
inherit eutils
@@ -31,7 +31,7 @@ RESTRICT="test"
pkg_setup() {
if ! use obex && ! use http; then
eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
- einfo "Please enable \"obex\" or/and \"http\" USE flags."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
die "Please enable \"obex\" or/and \"http\" USE flags."
fi
@@ -40,13 +40,13 @@ pkg_setup() {
eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
eerror "and \"obex\" USE flags, but dev-libs/openobex was built without"
eerror "the \"bluetooth\" USE flag."
- einfo "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
elif ! use obex; then
eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
eerror "USE flag, but you didn't enable the \"obex\" flag, which is"
eerror "needed for bluetooth support."
- einfo "Please enable \"obex\" USE flag."
+ eerror "Please enable \"obex\" USE flag."
die "Please enable \"obex\" USE flag."
fi
fi
diff --git a/app-pda/libsyncml/libsyncml-0.4.4.ebuild b/app-pda/libsyncml/libsyncml-0.4.4.ebuild
new file mode 100644
index 000000000000..f507f959f229
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-0.4.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.4.ebuild,v 1.1 2007/03/28 20:13:43 peper Exp $
+
+inherit eutils
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="bluetooth debug doc http obex"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libwbxml-0.9.2
+ dev-libs/libxml2
+ http? ( >=net-libs/libsoup-2.2.91 )
+ obex? ( >=dev-libs/openobex-1.1 )
+ bluetooth? ( net-wireless/bluez-libs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# Some of the tests are broken
+RESTRICT="test"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use bluetooth; then
+ if use obex && ! built_with_use dev-libs/openobex bluetooth; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "and \"obex\" USE flags, but dev-libs/openobex was built without"
+ eerror "the \"bluetooth\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ elif ! use obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but you didn't enable the \"obex\" flag, which is"
+ eerror "needed for bluetooth support."
+ eerror "Please enable \"obex\" USE flag."
+ die "Please enable \"obex\" USE flag."
+ fi
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable obex) \
+ $(use_enable http) \
+ $(use_enable debug) \
+ $(use_enable debug tracing) \
+ --disable-unit-tests \
+ || die "econf failed"
+ #$(use_enable test unit-tests) \
+
+ emake || die "emake failed"
+
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+
+ use doc && dohtml docs/html/*
+}