summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.06_rc1.ebuild2
-rw-r--r--sys-boot/grub/grub-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-boot/grub/grub-2.06_rc1.ebuild b/sys-boot/grub/grub-2.06_rc1.ebuild
index 39eb0acc06c7..19ad393f721d 100644
--- a/sys-boot/grub/grub-2.06_rc1.ebuild
+++ b/sys-boot/grub/grub-2.06_rc1.ebuild
@@ -146,6 +146,8 @@ src_prepare() {
if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
python_setup
+ else
+ export PYTHON=true
fi
if [[ -n ${GRUB_BOOTSTRAP} ]]; then
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 39eb0acc06c7..19ad393f721d 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -146,6 +146,8 @@ src_prepare() {
if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
python_setup
+ else
+ export PYTHON=true
fi
if [[ -n ${GRUB_BOOTSTRAP} ]]; then