summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-03-17 10:39:23 -0400
committerMike Gilbert <floppym@gentoo.org>2021-03-17 10:39:23 -0400
commit7a381a6a8c2e62b0ad7b98dcf57a6b933015487a (patch)
treeadd393c22e62c75b368092f5e6a338e7a65febb0 /sys-boot
parentsys-boot/grub: stub-out pkg_setup (diff)
downloadgentoo-7a381a6a8c2e62b0ad7b98dcf57a6b933015487a.tar.gz
gentoo-7a381a6a8c2e62b0ad7b98dcf57a6b933015487a.tar.bz2
gentoo-7a381a6a8c2e62b0ad7b98dcf57a6b933015487a.zip
sys-boot/grub: set PYTHON=true when not running autogen
Since 8b467844e1, configure.ac calls AM_PATH_PYTHON, but this is only used when re-generating automake input files. Closes: https://bugs.gentoo.org/776619 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.06_rc1.ebuild2
-rw-r--r--sys-boot/grub/grub-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-boot/grub/grub-2.06_rc1.ebuild b/sys-boot/grub/grub-2.06_rc1.ebuild
index 39eb0acc06c7..19ad393f721d 100644
--- a/sys-boot/grub/grub-2.06_rc1.ebuild
+++ b/sys-boot/grub/grub-2.06_rc1.ebuild
@@ -146,6 +146,8 @@ src_prepare() {
if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
python_setup
+ else
+ export PYTHON=true
fi
if [[ -n ${GRUB_BOOTSTRAP} ]]; then
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 39eb0acc06c7..19ad393f721d 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -146,6 +146,8 @@ src_prepare() {
if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
python_setup
+ else
+ export PYTHON=true
fi
if [[ -n ${GRUB_BOOTSTRAP} ]]; then