summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/topgit')
-rw-r--r--dev-vcs/topgit/Manifest1
-rw-r--r--dev-vcs/topgit/metadata.xml11
-rw-r--r--dev-vcs/topgit/topgit-0.9.ebuild34
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-vcs/topgit/Manifest b/dev-vcs/topgit/Manifest
new file mode 100644
index 000000000000..2cd5b6494e3b
--- /dev/null
+++ b/dev-vcs/topgit/Manifest
@@ -0,0 +1 @@
+DIST topgit-0.9.tar.gz 37025 SHA256 24b55f666e8d88ebf092a1df365492a659210a750c0793acb0c8560694203dfd SHA512 15b4ec44fb1711273155350924806f9ddce330251d3f300f5d2ecf445f4822c40b5c7309429876746ed8226c00f74292956f51f9126c8c359c3f4d589c73791c WHIRLPOOL 4a281723d518d5ea7326703187401870dc05a8fb84d23ab5cebf9b1edc70f0bf5770a9d032f5df67ff55c645750d848763aab503eec6dd9cd6d4c23f1cc8ec69
diff --git a/dev-vcs/topgit/metadata.xml b/dev-vcs/topgit/metadata.xml
new file mode 100644
index 000000000000..182cfab3c7a7
--- /dev/null
+++ b/dev-vcs/topgit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">greenrd/topgit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/topgit/topgit-0.9.ebuild b/dev-vcs/topgit/topgit-0.9.ebuild
new file mode 100644
index 000000000000..2e44c817849f
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://github.com/greenrd/topgit"
+SRC_URI="https://github.com/greenrd/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" sharedir="${D}/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}