summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/topgit/topgit-0.9.ebuild')
-rw-r--r--dev-vcs/topgit/topgit-0.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-vcs/topgit/topgit-0.9.ebuild b/dev-vcs/topgit/topgit-0.9.ebuild
new file mode 100644
index 000000000000..2e44c817849f
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://github.com/greenrd/topgit"
+SRC_URI="https://github.com/greenrd/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" sharedir="${D}/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}