summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpickle/jsonpickle-3.2.1.ebuild')
-rw-r--r--dev-python/jsonpickle/jsonpickle-3.2.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/jsonpickle/jsonpickle-3.2.1.ebuild b/dev-python/jsonpickle/jsonpickle-3.2.1.ebuild
index 3bed0a414fd2..155b209d25ad 100644
--- a/dev-python/jsonpickle/jsonpickle-3.2.1.ebuild
+++ b/dev-python/jsonpickle/jsonpickle-3.2.1.ebuild
@@ -38,8 +38,14 @@ BDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
- sed -i -e 's:--cov::' pytest.ini || die
+ local PATCHES=(
+ # https://github.com/jsonpickle/jsonpickle/pull/512
+ "${FILESDIR}/${P}-numpy-2.patch"
+ )
+
distutils-r1_python_prepare_all
+
+ sed -i -e 's:--cov::' pytest.ini || die
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
}