summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-14 15:54:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-14 15:55:00 +0200
commit1dc3765dcf40a74b6ea90b23eeb54cfcb70b0b73 (patch)
tree7c0cec0e7410461520829ef2953f5e3df291ad0d /dev-ros/settlerlib
parentnet-analyzer/snort: remove errant code block which should have been removed a... (diff)
downloadgentoo-1dc3765dcf40a74b6ea90b23eeb54cfcb70b0b73.tar.gz
gentoo-1dc3765dcf40a74b6ea90b23eeb54cfcb70b0b73.tar.bz2
gentoo-1dc3765dcf40a74b6ea90b23eeb54cfcb70b0b73.zip
dev-ros/settlerlib: fix build with gcc6, bug #594318
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/settlerlib')
-rw-r--r--dev-ros/settlerlib/files/gcc6.patch13
-rw-r--r--dev-ros/settlerlib/settlerlib-0.10.14.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-ros/settlerlib/files/gcc6.patch b/dev-ros/settlerlib/files/gcc6.patch
new file mode 100644
index 000000000000..4fe3a03fbe5e
--- /dev/null
+++ b/dev-ros/settlerlib/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: settlerlib/CMakeLists.txt
+===================================================================
+--- settlerlib.orig/CMakeLists.txt
++++ settlerlib/CMakeLists.txt
+@@ -9,7 +9,7 @@ catkin_package(DEPENDS Boost calibration
+ )
+
+ # common commands for building c++ executables and libraries
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/settlerlib/
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
diff --git a/dev-ros/settlerlib/settlerlib-0.10.14.ebuild b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
index e00b3046a233..bb9f2466b99e 100644
--- a/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
+++ b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,3 +22,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gcc6.patch" )