summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/settlerlib/files/gcc6.patch13
-rw-r--r--dev-ros/settlerlib/settlerlib-0.10.14.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-ros/settlerlib/files/gcc6.patch b/dev-ros/settlerlib/files/gcc6.patch
new file mode 100644
index 000000000000..4fe3a03fbe5e
--- /dev/null
+++ b/dev-ros/settlerlib/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: settlerlib/CMakeLists.txt
+===================================================================
+--- settlerlib.orig/CMakeLists.txt
++++ settlerlib/CMakeLists.txt
+@@ -9,7 +9,7 @@ catkin_package(DEPENDS Boost calibration
+ )
+
+ # common commands for building c++ executables and libraries
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/settlerlib/
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
diff --git a/dev-ros/settlerlib/settlerlib-0.10.14.ebuild b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
index e00b3046a233..bb9f2466b99e 100644
--- a/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
+++ b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,3 +22,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gcc6.patch" )