summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-12-24 22:34:19 +0100
committerLouis Sautier <sbraz@gentoo.org>2023-12-24 22:34:47 +0100
commitb52a6ae76d57e6b28cb3cc2382f230cae624cab9 (patch)
treea2ce269d9f6b9dcb6ad20c2ef59f49aaa958c5fb /dev-python/dominate/dominate-2.9.1.ebuild
parentdev-util/yamllint: add 1.33.0 (diff)
downloadgentoo-b52a6ae76d57e6b28cb3cc2382f230cae624cab9.tar.gz
gentoo-b52a6ae76d57e6b28cb3cc2382f230cae624cab9.tar.bz2
gentoo-b52a6ae76d57e6b28cb3cc2382f230cae624cab9.zip
dev-python/dominate: add 2.9.1
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/dominate/dominate-2.9.1.ebuild')
-rw-r--r--dev-python/dominate/dominate-2.9.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/dominate/dominate-2.9.1.ebuild b/dev-python/dominate/dominate-2.9.1.ebuild
new file mode 100644
index 000000000000..576830e8c74f
--- /dev/null
+++ b/dev-python/dominate/dominate-2.9.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="
+ https://github.com/Knio/dominate/
+ https://pypi.org/project/dominate/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest