summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-05-25 06:30:35 +0300
committerStefan Strogin <steils@gentoo.org>2020-05-25 06:36:27 +0300
commit52532f4abca9d9b82acc0277e041ea094ccb61dc (patch)
treeabf5a3b24b1b29f4091b4e2bb5c2c9477ab9ec76 /dev-libs
parentnet-misc/r8168: Fix comment in 8.048.02 (diff)
downloadgentoo-52532f4abca9d9b82acc0277e041ea094ccb61dc.tar.gz
gentoo-52532f4abca9d9b82acc0277e041ea094ccb61dc.tar.bz2
gentoo-52532f4abca9d9b82acc0277e041ea094ccb61dc.zip
dev-libs/libressl: version bump to 3.1.2
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-3.1.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index e2fb389aaa1d..cce81208481a 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -7,3 +7,4 @@ DIST libressl-3.0.1.tar.gz 3668819 BLAKE2B 0e0e9db5018f7fd6c5d3f15dd911e375ae518
DIST libressl-3.0.2.tar.gz 3669468 BLAKE2B 84ad2c1fea8d2119f191ec8ab3f999fb0354636d48aabb76fa1786139c669c9d8ca105d79cc8416dd20683818eccc84490cdadc9ca94cb2b0e411644e923a3d6 SHA512 19226da3bc9776e1da40b8e94dfa53564d5e6acc80edee539ba12d7a75c1bb8c0603e7633f26a6ef8b12adc56bb677ccda448575aa6be2ad3df5447465a4b080
DIST libressl-3.1.0.tar.gz 3758950 BLAKE2B 0ea1caa80ab54a5346f239dd1205f7fea56cf1a8a541766068c002647144ca6df0e32ff1bb451ebe42100eb27d08ce9afd4a13c2b2c5bab4ffcbcbeae7e4c94d SHA512 365ccf01d4802af048b2a03b6994b17cf051185fa4a0940ae72bd3ec3927467486501d334d2fa7904b07d9364093a97e1b90bb67d3bd8bb1d807643c20a0c677
DIST libressl-3.1.1.tar.gz 3765769 BLAKE2B 8524a4d83e05b0f2992df8e3797cbf43220a8619431f4737887db2fa35419a925907691ac1aec5b3cc1660179d4ac5e44714540ae591c5aa4957db1f26068a7e SHA512 353a5c95bb0c160b698b95b91d6857ddb63a75b0685a233ed2515f46ad8369d40857aa1ff8407aa9bc78a5c3c29c25376e7a55a3c96fce40840633411944fb1d
+DIST libressl-3.1.2.tar.gz 3765944 BLAKE2B b0181a1936af3aad3908668cae14aa87e8dca594ebb1effa354eb57529c21aca2052ce6bc85958dd83645c9026c84410939018d16c8e70a60f336145d45790e6 SHA512 b024c5661777daa73feff7085ce7be76a2e766d2f3cb5ca35c208c471e5651a365252758ca36782e20cdfb2bc8171919a08ad592420878a5c95fbe646f5288c8
diff --git a/dev-libs/libressl/libressl-3.1.2.ebuild b/dev-libs/libressl/libressl-3.1.2.ebuild
new file mode 100644
index 000000000000..ab31f2041689
--- /dev/null
+++ b/dev-libs/libressl/libressl-3.1.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal libtool
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/48"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+asm static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ if ! use test ; then
+ sed -i \
+ -e '/^[ \t]*SUBDIRS =/s#tests##' \
+ Makefile.in || die "Removing tests failed"
+ fi
+
+ eapply "${FILESDIR}"/${PN}-2.8.3-solaris10.patch
+ eapply_user
+
+ elibtoolize # for Solaris
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}